Bug 1417276 - ipfailover keepalived split brain [NEEDINFO]
Summary: ipfailover keepalived split brain
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 3.2.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 3.4.z
Assignee: Phil Cameron
QA Contact: Meng Bo
URL:
Whiteboard:
Depends On: 1402536 1417282
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-27 18:59 UTC by Phil Cameron
Modified: 2017-02-22 18:11 UTC (History)
12 users (show)

Fixed In Version: OSE 3.4 PR 573
Doc Type: Bug Fix
Doc Text:
Bug fix. Fixes a regression. No doc changes.
Clone Of: 1402536
Environment:
Last Closed: 2017-02-22 18:11:35 UTC
Target Upstream Version:
pcameron: needinfo? (akokshar)


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Origin (Github) 12399 0 None None None 2017-01-27 18:59:55 UTC
Red Hat Product Errata RHBA-2017:0289 0 normal SHIPPED_LIVE OpenShift Container Platform 3.4.1.7, 3.3.1.14, and 3.2.1.26 bug fix update 2017-02-22 23:10:04 UTC

Comment 1 Phil Cameron 2017-01-27 19:02:50 UTC
Ported 3.2 version into 3.3

Comment 2 Troy Dawson 2017-02-02 22:17:24 UTC
Full URL's to pull requests are much more helpful than just a number.  Since this bug is for 3.4, that pull request is here.
https://github.com/openshift/ose/pull/573
We still don't have a 3.4 build with this in it, I'm just cleaning up the bugs.

Comment 3 Troy Dawson 2017-02-10 22:59:30 UTC
This has been merged into ocp and is in OCP v3.4.1.7 or newer.

Comment 5 Meng Bo 2017-02-13 09:49:12 UTC
Checked on OCP build v3.4.1.7 and image ose-keepalived-ipfailover   v3.4.1.7            9157d0d74862

Issue has been fixed.

Comment 15 errata-xmlrpc 2017-02-22 18:11:35 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:0289


Note You need to log in before you can comment on or make changes to this bug.