Bug 1417290 - C&U Charting error when displaying 4 weeks of data [NEEDINFO]
Summary: C&U Charting error when displaying 4 weeks of data
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.7.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: GA
: 5.9.0
Assignee: Robin Knaur
QA Contact: Nandini Chandra
URL:
Whiteboard: c&u:ui
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-27 20:05 UTC by Roderick Moore
Modified: 2017-07-21 10:39 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-07-21 10:39:01 UTC
Category: Bug
Cloudforms Team: CFME Core
Target Upstream Version:
rknaur: needinfo? (rmoore)


Attachments (Terms of Use)
example of charting error (78.90 KB, image/png)
2017-01-27 20:05 UTC, Roderick Moore
no flags Details
Screen shot from 5.8 where issue is not seen (84.26 KB, image/png)
2017-05-17 18:34 UTC, Nandini Chandra
no flags Details

Description Roderick Moore 2017-01-27 20:05:06 UTC
Created attachment 1245264 [details]
example of charting error

Description of problem: When viewing 4 weeks of data in a C&U chart the x axis compresses most of the data points in the first few mm of space


Version-Release number of selected component (if applicable):5.7.0.17.20161219135818_725f92f


How reproducible: Ive been able to reproduce it in both Firefox and Chrome


Steps to Reproduce:
1. Navigate to a cluster
2. select utilization from the monitoring menu
3. change the show menu to 4 weeks

Actual results:


Expected results:


Additional info: I've attached a screenshot

Comment 2 Roderick Moore 2017-01-27 20:09:33 UTC
I just tried the 1, 2 and 3 week options and they all display the data properly. The issue is only seen when selecting the 4 weeks option

Comment 3 Robin Knaur 2017-02-13 14:20:26 UTC
I am not able to reproduce it, 4 weeks option works same as 1, 2 and 3 option for me. It's broken for every 4 weeks chart or just this particular one? 
Could you give me the response you get from wait_for_task in your browser for this broken chart?

Comment 6 Nandini Chandra 2017-05-17 18:34:44 UTC
Created attachment 1279778 [details]
Screen shot from 5.8 where issue is not seen

Comment 7 Robin Knaur 2017-06-26 13:53:06 UTC
Hey Roderick,

since it is working in 5.8. and target release is cfme-future, is it ok if i close it?

Thanks


Note You need to log in before you can comment on or make changes to this bug.