Bug 1417295 - New 1.8.0.111-5.b16.fc25 build of java-1.8.0-openjdk seg faults on azureus startup
Summary: New 1.8.0.111-5.b16.fc25 build of java-1.8.0-openjdk seg faults on azureus st...
Keywords:
Status: CLOSED DUPLICATE of bug 1415137
Alias: None
Product: Fedora
Classification: Fedora
Component: java-1.8.0-openjdk
Version: 25
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Deepak Bhole
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-27 20:44 UTC by John Gotts
Modified: 2017-01-27 21:20 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-27 21:20:20 UTC
Type: Bug


Attachments (Terms of Use)
Detailed information explaining the crash. (105.93 KB, text/plain)
2017-01-27 20:44 UTC, John Gotts
no flags Details

Description John Gotts 2017-01-27 20:44:29 UTC
Created attachment 1245267 [details]
Detailed information explaining the crash.

Description of problem:
The new January 15th build of java-1.8.0-openjdk reproducibly seg faults when starting azureus. azureus had been running fine over approximately 5-10 versions of Fedora.

Version-Release number of selected component (if applicable):
1.8.0.111-5.b16.fc25

How reproducible:
Always.

Steps to Reproduce:
1. azureus &
2.
3.

Actual results:
Starting Azureus...
GRE/XULRunner automatically found
Loading Azureus:
/usr/lib/jvm/jre/bin/java  -cp "/usr/lib64/eclipse/swt.jar:/usr/share/java/json_simple.jar:/usr/share/java/bcprov.jar:/usr/share/java/apache-commons-cli.jar:/usr/share/java/apache-commons-lang.jar:/usr/share/java/log4j-1.jar:/usr/share/azureus/Azureus2.jar:./*.jar" -Djava.library.path="/home/jgotts/.azureus/app" -Dazureus.install.path="/home/jgotts/.azureus/app" -Dazureus.script="/usr/bin/azureus" -Dazureus.script.version=5 -Dorg.eclipse.swt.browser.UseWebKitGTK=true -Dazureus.skipSWTcheck=1 org.gudy.azureus2.ui.swt.Main 
openjdk version "1.8.0_111"
OpenJDK Runtime Environment (build 1.8.0_111-b16)
OpenJDK 64-Bit Server VM (build 25.111-b16, mixed mode)
file:/usr/lib64/eclipse/swt.jar ; file:/usr/share/java/json_simple.jar ; file:/usr/share/java/bcprov.jar ; file:/usr/share/java/commons-cli.jar ; file:/usr/share/java/apache-commons-lang.jar ; file:/usr/share/java/log4j-1.2.17.jar ; file:/usr/share/azureus/Azureus2.jar ; file:/home/jgotts/.azureus/app/*.jar ; file:/home/jgotts/.azureus/app/
changeLocale: *Default Language* != English (United States). Searching without country..
changeLocale: Searching for language English in *any* country..
changeLocale: no message properties for Locale 'English (United States)' (en_US), using 'English (default)'
UIFunctions/ImageLoad took 0ms
new shell took 179ms
new shell setup took 25ms
skin init took 128ms
MainMenu init took 101ms
pre skin widgets init took 25ms
#
# A fatal error has been detected by the Java Runtime Environment:
#
#  SIGSEGV (0xb) at pc=0x00007f47e5546b84, pid=11594, tid=0x00007f4744861700
#
# JRE version: OpenJDK Runtime Environment (8.0_111-b16) (build 1.8.0_111-b16)
# Java VM: OpenJDK 64-Bit Server VM (25.111-b16 mixed mode linux-amd64 compressed oops)
# Problematic frame:
# C  [libc.so.6+0x90b84]  __memcpy_sse2_unaligned_erms+0x1a4
#
# Core dump written. Default location: /home/jgotts/.azureus/app/core or core.11594
#
# An error report file with more information is saved as:
# /home/jgotts/.azureus/app/hs_err_pid11594.log
#
# If you would like to submit a bug report, please visit:
#   http://bugreport.java.com/bugreport/crash.jsp
#

Expected results:
azureus starts.

Additional info:
Attached is the detailed log that azureus produces when it crashes.

Comment 1 Omair Majid 2017-01-27 21:20:20 UTC
Thanks for the crash log! This looks like a duplicate. It should be fixed by https://bodhi.fedoraproject.org/updates/FEDORA-2017-4076cf8494

*** This bug has been marked as a duplicate of bug 1415137 ***


Note You need to log in before you can comment on or make changes to this bug.