Bug 1417298 - rhos-director: overcloud deployment fails right way: The template is not a JSON object or YAML mapping
Summary: rhos-director: overcloud deployment fails right way: The template is not a JS...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 11.0 (Ocata)
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 11.0 (Ocata)
Assignee: Angus Thomas
QA Contact: Omri Hochman
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-27 20:58 UTC by Alexander Chuzhoy
Modified: 2017-05-17 19:43 UTC (History)
7 users (show)

Fixed In Version: openstack-tripleo-heat-templates-6.0.0-2.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-17 19:43:53 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:1245 normal SHIPPED_LIVE Red Hat OpenStack Platform 11.0 Bug Fix and Enhancement Advisory 2017-05-17 23:01:50 UTC

Description Alexander Chuzhoy 2017-01-27 20:58:25 UTC
rhos-director: overcloud deployment fails right way: The template is not a JSON object or YAML mapping

Environment:
instack-undercloud-6.0.0-0.20170120171137.c891931.el7ost.noarch
openstack-puppet-modules-9.3.0-0.20170111174831.8c758d6.el7ost.noarch
openstack-tripleo-heat-templates-6.0.0-0.20170120220934.el7ost.noarch


Steps to reproduce:
Attempt to start an overcloud deployment.

Result:

Removing the current plan files
Uploading new plan files
Started Mistral Workflow tripleo.plan_management.v1.update_deployment_plan. Execution ID: f93ed6fa-76d3-4a34-bfca-9af42409bcd2
Plan updated
Deploying templates in the directory /tmp/tripleoclient-tPdcNx/tripleo-heat-templates
Started Mistral Workflow tripleo.deployment.v1.deploy_plan. Execution ID: 8e57f9e4-2c5b-4fef-901b-83a91ba129b9
{u'execution': {u'id': u'8e57f9e4-2c5b-4fef-901b-83a91ba129b9',
                u'input': {u'container': u'overcloud',
                           u'queue_name': u'386cb81b-6482-4614-b036-f998262a360d',
                           u'timeout': 240},
                u'name': u'tripleo.deployment.v1.deploy_plan',
                u'params': {},
                u'spec': {u'description': u'Deploy the overcloud for a plan.\n',
                          u'input': [u'container',
                                     {u'timeout': 240},
                                     {u'queue_name': u'tripleo'}],
                          u'name': u'deploy_plan',
                          u'tasks': {u'add_validation_ssh_key': {u'input': {u'container': u'<% $.container %>',
                                                                            u'queue_name': u'<% $.queue_name %>'},
                                                                 u'name': u'add_validation_ssh_key',
                                                                 u'on-complete': u'get_heat_stack',
                                                                 u'type': u'direct',
                                                                 u'version': u'2.0',
                                                                 u'workflow': u'tripleo.validations.v1.add_validation_ssh_key_parameter'},
                                     u'deploy': {u'action': u'tripleo.deployment.deploy timeout=<% $.timeout %> container=<% $.container %>',
                                                 u'name': u'deploy',
                                                 u'on-error': u'set_deployment_failed',
                                                 u'on-success': u'send_message',
                                                 u'type': u'direct',
                                                 u'version': u'2.0'},
                                     u'fail_workflow': {u'action': u'std.fail',
                                                        u'name': u'fail_workflow',
                                                        u'type': u'direct',
                                                        u'version': u'2.0'},
                                     u'get_heat_stack': {u'action': u'heat.stacks_get stack_id=<% $.container %>',
                                                         u'name': u'get_heat_stack',
                                                         u'on-error': u'deploy',
                                                         u'on-success': [{u'set_stack_in_progress': u'<% "_IN_PROGRESS" in task(get_heat_stack).result.stack_status %>'},
                                                                         {u'deploy': u'<% not "_IN_PROGRESS" in task(get_heat_stack).result.stack_status %>'}],
                                                         u'type': u'direct',
                                                         u'version': u'2.0'},
                                     u'send_message': {u'action': u'zaqar.queue_post',
                                                       u'input': {u'messages': {u'body': {u'payload': {u'execution': u'<% execution() %>',
                                                                                                       u'message': u"<% $.get('message', '') %>",
                                                                                                       u'status': u"<% $.get('status', 'SUCCESS') %>"},
                                                                                          u'type': u'tripleo.deployment.v1.deploy_plan'}},
                                                                  u'queue_name': u'<% $.queue_name %>'},
                                                       u'name': u'send_message',
                                                       u'on-success': [{u'fail_workflow': u'<% $.get(\'status\') = "FAILED" %>'}],
                                                       u'retry': u'count=5 delay=1',
                                                       u'type': u'direct',
                                                       u'version': u'2.0'},
                                     u'set_deployment_failed': {u'name': u'set_deployment_failed',
                                                                u'on-success': u'send_message',
                                                                u'publish': {u'message': u'<% task(deploy).result %>',
                                                                             u'status': u'FAILED'},
                                                                u'type': u'direct',
                                                                u'version': u'2.0'},
                                     u'set_stack_in_progress': {u'name': u'set_stack_in_progress',
                                                                u'on-success': u'send_message',
                                                                u'publish': {u'message': u'The Heat stack is busy.',
                                                                             u'status': u'FAILED'},
                                                                u'type': u'direct',
                                                                u'version': u'2.0'}},
                          u'version': u'2.0'}},
 u'message': u"Failed to run action [action_ex_id=96938d69-46c6-4ba1-bcae-16e178c6184d, action_cls='<class 'mistral.actions.action_factory.DeployStackAction'>', attributes='{}', params='{u'container': u'overcloud', u'timeout': 240}']\n ERROR: Failed to validate: : resources.AllNodesDeploySteps: : The template is not a JSON object or YAML mapping.",
 u'status': u'FAILED'}


Expected result:
The deployment should start.

Comment 1 Alexander Chuzhoy 2017-01-27 21:23:47 UTC
the issue is fixed by this RPM:
openstack-tripleo-heat-templates-6.0.0-0.20170120220935.el7ost.noarch

Comment 2 Alexander Chuzhoy 2017-01-28 03:41:31 UTC
The fix came in:
openstack-tripleo-heat-templates-6.0.0-0.20170120220935.el7ost.noarch

Verified by successfully installing.

Comment 5 errata-xmlrpc 2017-05-17 19:43:53 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1245


Note You need to log in before you can comment on or make changes to this bug.