Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1417303 - Sat6 has a hard limit of 64k Content Hosts running katello agent
Summary: Sat6 has a hard limit of 64k Content Hosts running katello agent
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Qpid
Version: 6.2.8
Hardware: x86_64
OS: Linux
high
high
Target Milestone: Unspecified
Assignee: Mike Cressman
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-27 21:33 UTC by Pavel Moravec
Modified: 2019-04-01 20:27 UTC (History)
16 users (show)

Fixed In Version: qpid-dispatch-0.8.0-10
Doc Type: Enhancement
Doc Text:
Previously, Satellite had a hard limit of 64k Content Hosts that can run katello agent. The Qpid Dispatch Router has been improved to remove this limit.
Clone Of:
Environment:
Last Closed: 2018-02-21 12:57:01 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0338 0 normal SHIPPED_LIVE Red Hat Satellite 6.3 Tools 2018-02-21 19:30:02 UTC

Description Pavel Moravec 2017-01-27 21:33:18 UTC
Description of problem:
Currently, any katello agent requires 1 (sometimes 2) connection(s) / AMQP link(s) via qdrouterd topology to qpidd. The only (TCP and AMQP) connection between qpidd and qdrouterd aggregates all sessions from all Content Hosts. 

Per AMQP1.0 specification, one AMQP connection can handle up to 65535 channels/sessions per one AMQP connection.

Therefore, in the current design, Satellite has a hard limit of 64k Content Hosts that can run katello agent.


Version-Release number of selected component (if applicable):
(any)


How reproducible:
100% (I guess)


Steps to Reproduce:
1. Try to run katello agent on >65535 Content Hosts managed by one Satellite via arbitrary number of Capsules


Actual results:
1. shall not be feasible


Expected results:
1. shall be feasible


Additional info:
Potential solutions:
- change proton implementing AMQP such that it allows more sessions. proton library would violate AMQP specification, then
- change/extend qdrouterd (or proton?) behaviour such that when it needs to open a session "over the limit", let open a new AMQP connection on the same TCP connection first
- optionally to the above, open a new TCP connection instead (such that 1 TCP connection does not deliver all the traffic for all the >64k clients)

Comment 3 David Caplan 2017-01-31 18:15:02 UTC
Satellite's upper bounds are limited by AMQP's ceiling. Is this an artifact of a particular version of AMQP (QPID).

Comment 5 Ted Ross 2017-03-06 13:35:07 UTC
(In reply to David Caplan from comment #3)
> Satellite's upper bounds are limited by AMQP's ceiling. Is this an artifact
> of a particular version of AMQP (QPID).

This is a Qpid Dispatch Router issue, not an AMQP issue.  AMQP can handle all of the links you need.  We will address this limitation in the router in an upcoming release.

-Ted

Comment 18 errata-xmlrpc 2018-02-21 12:57:01 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0338


Note You need to log in before you can comment on or make changes to this bug.