Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1417342 - schema reload task picks up schema when the validation fails.
Summary: schema reload task picks up schema when the validation fails.
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: 389-ds-base
Version: 7.3
Hardware: Unspecified
OS: Unspecified
medium
unspecified
Target Milestone: rc
: ---
Assignee: Noriko Hosoi
QA Contact: Viktor Ashirov
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-28 02:16 UTC by Noriko Hosoi
Modified: 2020-09-13 21:55 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-10-02 19:18:17 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github 389ds 389-ds-base issues 2151 0 None None None 2020-09-13 21:55:54 UTC

Description Noriko Hosoi 2017-01-28 02:16:42 UTC
This bug is created as a clone of upstream ticket:
https://fedorahosted.org/389/ticket/49092

Note: found in debugging/testing ticket 47973.

Steps:

cat > /path/to/99user.ldif << EOF
dn: cn=schema
attributetypes: ( 8.9.10.11.12.13.14 NAME 'MozillaAttribute' SYNTAX 1.3.6.1.4.1.1466.115.121.1.15 X-ORIGIN 'Mozilla Dummy Schema' )
objectclasses: ( 1.2.3.4.5.6.7 NAME 'MozillaObject' SUP top MUST ( objectclass $ cn ) MAY ( givenName $ sn $ MozillaAttribute ) X-ORIGIN 'user defined' )
EOF

schema-reload.pl -Z SERVERINST -D 'cn=directory manager' -W
<== expect to success

ldapsearch returns, e.g. "MAY ( givenName $ sn $ MozillaAttribute )"

cat > /path/to/98user.ldif << EOF
dn: cn=schema
attributetypes: ( 8.9.10.11.12.13.140 NAME 'MozillaAttribute' SYNTAX 1.3.6.1.4.1.1466.115.121.1.15 X-ORIGIN 'Mozilla Dummy Schema' )
objectclasses: ( 1.2.3.4.5.6.70 NAME 'MoZiLLaOBJeCT' SUP top MUST ( objectclass $ cn ) MAY ( givenName $ sn $ MoZiLLaATTRiBuTe ) X-ORIGIN 'user defined' )
EOF
Note: the objectclasses and attributetypes have different OIDs.

schema-reload.pl -Z SERVERINST -D 'cn=directory manager' -W
<== expect to fail.  check it in the error log.

Although the reload failed, ldapsearch returns, e.g. 1.2.3.4.5.6.70 and "MAY ( givenName $ sn $ MoZiLLaATTRiBuTe )"

If you try to restart the server, it refuses to start due to the invalid schema.

The problem is observed on rhel6 as well as on the local build from the master branch.

Comment 1 mreynolds 2017-10-02 19:18:17 UTC
I can not reproduce this behavior on 389-ds-base-1.3.7 - adding CI test upstream.


Note You need to log in before you can comment on or make changes to this bug.