Bug 1417369 - gdb segfault during symbol completion
Summary: gdb segfault during symbol completion
Keywords:
Status: CLOSED DUPLICATE of bug 1398387
Alias: None
Product: Fedora
Classification: Fedora
Component: gdb
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jan Kratochvil
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-28 10:57 UTC by Georg Sauthoff
Modified: 2017-01-29 20:52 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-29 20:52:00 UTC
Type: Bug


Attachments (Terms of Use)
backtrace (4.06 KB, text/plain)
2017-01-28 10:57 UTC, Georg Sauthoff
no flags Details

Description Georg Sauthoff 2017-01-28 10:57:09 UTC
Created attachment 1245385 [details]
backtrace

Description of problem:
GDB segfaults during symbol completion.

Version-Release number of selected component (if applicable):
gdb-7.12-36.fc25.x86_64
curl-7.51.0-4.fc25.x86_64
readline-6.3-8.fc24.x86_64

How reproducible:
almost always

Steps to Reproduce:
1. install curl
2. gdb -nh curl
3. type: b c<TAB>

Actual results:
$ gdb -nh curl
Reading symbols from curl...Reading symbols from /usr/lib/debug/usr/bin/curl.debug...done.
done.
(gdb) b czsh: segmentation fault (core dumped)  gdb -q -nh curl

Expected results:
a list of all symbols starting with c

Additional info:
it also segfaults without the curl debuginfo package being installed.

Comment 1 Jan Kratochvil 2017-01-29 20:52:00 UTC

*** This bug has been marked as a duplicate of bug 1398387 ***


Note You need to log in before you can comment on or make changes to this bug.