Bug 1417374 - MIME associations do not work with Chromium
Summary: MIME associations do not work with Chromium
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: chromium
Version: 25
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Tom "spot" Callaway
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-28 11:59 UTC by Andrew Zabolotny
Modified: 2017-06-15 17:32 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-06-15 17:32:52 UTC
Type: Bug


Attachments (Terms of Use)

Description Andrew Zabolotny 2017-01-28 11:59:04 UTC
Description of problem:
When clicking on any MIME content that browser can't handle, it will download it rather than opening it with the default MIME handler for this file type.

Version-Release number of selected component (if applicable):
chromium-55.0.2883.87-1.fc24.R.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Install chromium and transmission-qt packages
2. Open the following URL in Chromium:
http://cdimage.debian.org/debian-cd/current/amd64/bt-cd/debian-8.7.1-amd64-CD-1.iso.torrent

Actual results:
It will either download the file into your "Downloads" directory, or ask for a download location, depending on browser settings.

Expected results:
Should either allow to choose between download/launch, or launch with the default MIME file type handler.

Additional info:
Response header for the above URL contains:
Content-Type: application/x-bittorrent

The command:
xdg-mime query default application/x-bittorrent
reports "transmission-qt.desktop"

Comment 1 Tom "spot" Callaway 2017-06-14 16:13:56 UTC
Filed upstream as https://bugs.chromium.org/p/chromium/issues/detail?id=733293

Comment 2 Tom "spot" Callaway 2017-06-15 17:32:52 UTC
Okay. Upstream confirms that this is the intended behavior (not to open any downloads until the user clicks on it). You can override this by editing your ~/.config/chromium/Default/Preferences file. Search for:

"extensions_to_open":""

and change it to:

"extensions_to_open":"torrent"

You can also accomplish this by clicking the ^ next to the downloaded torrent and selecting "Always open files of this type".


Note You need to log in before you can comment on or make changes to this bug.