Bug 141742 - Unable to use driver disks with diskdump-enabled driver
Unable to use driver disks with diskdump-enabled driver
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: anaconda (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-03 09:01 EST by Martin Wilck
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-03 09:46:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Wilck 2004-12-03 09:01:34 EST
Description of problem:
When using a driver disk with RHEL3 U3 containing a driver that
supports diskdump, loading the driver disk will fail because loader is
unable to locate the "diskdumplib" module.


Version-Release number of selected component (if applicable):
9.1.3

How reproducible:
Always

Steps to Reproduce:
1.create dd with diskdump-enabled driver
2.install with "linux dd"
3.insert floppy and hit "ok" when asked
  
Actual results:
loading the driver fails with unresolved symbols from diskdumplib

Expected results:
diskdumplib dependency is resolved, module is loaded.

Additional info:
I made a "modules.dep" file on the dd that looks as follows:
a320raid: scsi_mod diskdumplib
Comment 1 Martin Wilck 2004-12-03 09:03:53 EST
I found the following workaround:

After dd loading fails, select "choose manually" and select a driver
thatsupports diskdump natively such as mptbase. even if loading that
driver fails, diskdumplib will now be loaded and a 2nd attempt to load
the dd will succeed.

This is of course less than optimal.

Another workaround would be to disable diskdump in the drivers for the
BOOT kernel. Also sub-optimal.
Comment 2 Jeremy Katz 2004-12-03 09:46:30 EST
You need to include the diskdumplib module on your driver disk.  All
dependent modules that aren't in the "loaded by default list" (which
is basically just scsi_mod, sd_mod) need to be on your driver disk.
Comment 3 Martin Wilck 2004-12-03 12:47:47 EST
I can do that.

It doesn't make sense to me though. Why should a native RedHat driver
have to be on the disk? All that would be needed is to have the loader
look for modules first on the driver disk and then in the default
location. I'd expect this behavior, actually.

So, I accept this as a temporary workaround, but I'd consider it more
than desirable that this be fixed in future releases.

Note You need to log in before you can comment on or make changes to this bug.