Bug 1417421 - RHEL mutt patch breaks rendering
Summary: RHEL mutt patch breaks rendering
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: mutt
Version: 6.9
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Matej Mužila
QA Contact: BaseOS QE - Apps
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-29 03:15 UTC by Chris Adams
Modified: 2017-04-12 10:21 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-04-10 12:46:46 UTC
Target Upstream Version:
mmuzila: needinfo-


Attachments (Terms of Use)

Description Chris Adams 2017-01-29 03:15:43 UTC
The patch mutt-1.5.20-cmdline_tls_segfault.patch causes mutt to mess up colors in the index when I have "arrow_cursor" set.  Instead of just the arrow at the left being highlighted, the whole line gets highlighted, and when I move up and down in the index, the arrow leaves white blanks behind in some spots.

I tried to look at the relevant bug, but it is private (BZ 1083524).

Without being able to see the bug, I'm not sure how curses and TLS combine to cause a problem (or how curses even is involved in sending a message from the command line).  I'm guessing that the problem is related to attrset()?  Does that exist in both curses and something else?

I have little experience programming with curses, but reading docs, it doesn't sound like attrset() and bkgdset() have quite the same semantics; for example, attrset() overrides existing attributes, while bkgdset() does not.

Comment 2 Matej Mužila 2017-02-03 14:16:41 UTC
Hi,

could you give me the version-release number of the package you use please?

Comment 3 Chris Adams 2017-02-03 14:21:24 UTC
I have this problem with mutt-1.5.20-7.20091214hg736b6a.el6.  I rebuilt the RPM excluding just the referenced patch, and that fixes the arrow_cursor problem for me.

Comment 5 Honza Horak 2017-04-10 08:22:16 UTC
Chris, do you have an idea whether the same issue is seen on RHEL 7?

Comment 6 Matej Mužila 2017-04-10 12:18:32 UTC
Hi Honza,

the issue is not present on RHEL 7.

Comment 7 Honza Horak 2017-04-10 12:46:46 UTC
OK, thanks, then I'd say let's close it.


Note You need to log in before you can comment on or make changes to this bug.