Bug 1417454 - Add driver jc42 to support temperature sensors on memory modules
Summary: Add driver jc42 to support temperature sensors on memory modules
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-29 14:48 UTC by Woi
Modified: 2019-01-09 12:54 UTC (History)
9 users (show)

Fixed In Version: kernel-4.9.9-200.fc25
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-13 22:23:34 UTC
Type: Bug


Attachments (Terms of Use)

Description Woi 2017-01-29 14:48:28 UTC
Description of problem:
Temperature of RAM modules with a temperature sensor on it can not be read.

Version-Release number of selected component (if applicable):
kernel 4.9.5-200.fc25

How reproducible:
Get memory modules with a temperature sensor on it. In my case:
$ sudo dmidecode -t memory|grep -e Part -e Manufacturer |grep -v Empty
	Manufacturer: Micron
	Part Number: 18JSF1G72AZ-1G9E1 
	Manufacturer: Micron
	Part Number: 18JSF1G72AZ-1G9E1

Mainboard may matter as well:
$ sudo inxi -M
Machine:   Device: desktop System: ASUS product: All Series
           Mobo: ASUSTeK model: P9D WS v: Rev 1.xx serial: XXXXXXXXX
           BIOS: ASUSTeK (Licensed from AMI) v: 2202 date: 05/14/2015


Steps to Reproduce:
1. Install lm_sensors

2. run sensors-detect

3. Probe for "Next adapter: SMBus I801 adapter at f000 (i2c-9)":
Do you want to scan it? (YES/no/selectively): YES
Client found at address 0x19
[...]
Probing for `Microchip MCP98243'...                         Success!
    (confidence 5, driver `jc42')
[...]
Client found at address 0x1b
[...]
Probing for `Microchip MCP98243'...                         Success!
    (confidence 5, driver `jc42')
[...]

4: See results:
Now follows a summary of the probes I have just done.
Just press ENTER to continue: 
[...]
Driver `jc42':
  * Bus `SMBus I801 adapter at f000'
    Busdriver `i2c_i801', I2C address 0x19
    Chip `Microchip MCP98243' (confidence: 5)
  * Bus `SMBus I801 adapter at f000'
    Busdriver `i2c_i801', I2C address 0x1b
    Chip `Microchip MCP98243' (confidence: 5)

5: Try to load module jc42:
$ sudo modprobe jc42

6: Prove fedora kernel has no jc42 enabled:
grep -i jc42 /boot/config-$(uname -r) 


Actual results:
For step 5: modprobe: FATAL: Module jc42 not found in directory /lib/modules/4.9.5-200.fc25.x86_64
For step 6: # CONFIG_SENSORS_JC42 is not set


Expected results:
For step 5: Module loads
For step 6: CONFIG_SENSORS_JC42=m

Additional info:
* Fedoras sensors-detect started to detect jc42 a few month a go.
* Datasheet for DIMMs: https://www.micron.com/parts/modules/ddr3-sdram/mt18jsf1g72az-1g9
* Driver documentation: https://www.kernel.org/doc/Documentation/hwmon/jc42
* Driver history: https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/log/drivers/hwmon/jc42.c

Comment 1 Laura Abbott 2017-02-01 22:02:26 UTC
The option has been turned on in rawhide. Please test it there. If it works okay, we can evaluate turning it on for F25.

Comment 2 Woi 2017-02-01 23:46:30 UTC
Thanks Laura.

I used the kernel from http://dl.fedoraproject.org/pub/alt/rawhide-kernel-nodebug/fedora-rawhide-kernel-nodebug.repo on my Fedora 25, but it looks like I was a bit to quick:

$ grep -i jc42 /boot/config-$(uname -r) 
# CONFIG_SENSORS_JC42 is not set

$uname -a
Linux phoenix.localdomain 4.10.0-0.rc6.git1.2.fc26.x86_64 #1 SMP Tue Jan 31 22:53:03 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux


I'll try again in a few days. However can you already explain when you consider it to "work okay" and what needs to be done to evaluate it for F25?
Is loading jc42 and reading temperatures sufficient? Do you want me to work with jc42 loaded for X days? Are there some test I should run?

Comment 3 Laura Abbott 2017-02-02 15:28:43 UTC
yes, it should be in the git2 build which should come out either today or tomorrow depending on the release process. Loading and reading the temperatures should be fine, just enough to know it is actually working as you expect.

Comment 4 Woi 2017-02-04 16:49:28 UTC
Works as expected. Temperatures have sane values between ~37°C at idle and ~50°C after a few minutes running prime95.

$ sensors|grep jc42 -A4
jc42-i2c-9-19
Adapter: SMBus I801 adapter at f000
temp1:        +37.0°C  (low  =  +0.0°C)                  ALARM (HIGH, CRIT)
                       (high =  +0.0°C, hyst =  +0.0°C)
                       (crit =  +0.0°C, hyst =  +0.0°C)
--
jc42-i2c-9-1b
Adapter: SMBus I801 adapter at f000
temp1:        +37.8°C  (low  =  +0.0°C)                  ALARM (HIGH, CRIT)
                       (high =  +0.0°C, hyst =  +0.0°C)
                       (crit =  +0.0°C, hyst =  +0.0°C)

$ uname -r
4.10.0-0.rc6.git2.2.fc26.x86_64

Could you please enable CONFIG_SENSORS_JC42 for regular f25 kernels, so I can install form bodhi or updates-testing to test it in everyday use?

Since you closed this ticket: Should I create a new ticket for it?

Comment 5 Laura Abbott 2017-02-08 00:22:38 UTC
No need, I enabled the option on F25. Won't make 4.9.8 but should be in 4.9.9

Comment 6 Fedora Update System 2017-02-09 23:46:26 UTC
kernel-4.9.9-200.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-fb89ca752a

Comment 7 Fedora Update System 2017-02-10 16:23:32 UTC
kernel-4.9.9-200.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-fb89ca752a

Comment 8 Fedora Update System 2017-02-10 16:43:42 UTC
kernel-4.9.9-100.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2017-92d84f68cf

Comment 9 Woi 2017-02-10 19:10:56 UTC
That was quicker than expected. Work's as expected, I provided Karma on bodhi accordingly.
Thanks a lot and have a nice weekend

Comment 10 Fedora Update System 2017-02-11 16:48:07 UTC
kernel-4.9.9-100.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-92d84f68cf

Comment 11 Fedora Update System 2017-02-13 22:23:34 UTC
kernel-4.9.9-200.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2017-02-13 22:48:18 UTC
kernel-4.9.9-100.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2017-02-14 15:49:30 UTC
kernel-4.9.9-200.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.