Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1417465 - Host Config issue with oc client v 3.4.0.40 and oc cluster up
Summary: Host Config issue with oc client v 3.4.0.40 and oc cluster up
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: oc
Version: 3.4.0
Hardware: All
OS: Windows
unspecified
high
Target Milestone: ---
: 3.4.z
Assignee: Cesar Wong
QA Contact: Wenjing Zheng
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-29 16:19 UTC by Veer Muchandi
Modified: 2017-02-06 15:34 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-06 15:34:34 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Veer Muchandi 2017-01-29 16:19:08 UTC
Description of problem:
oc cluster up does not come up. It fails with API Error while creating Openshift Configuration.

Version-Release number of selected component (if applicable):
oc client v 3.4.0.40
openshift version registry.access.redhat.com/openshift3/ose:v3.4.0.40

How reproducible:

easy


Steps to Reproduce:
1. On a windows box install oc client
2. run oc cluster up with our without --host-config option
Notice this error



Actual results:
oc cluster up  --host-config-dir=c:/users/veer/openshift/hostconfig
-- Checking OpenShift client ... OK
-- Checking Docker client ... OK
-- Checking Docker version ... OK
-- Checking for existing OpenShift container ... OK
-- Checking for registry.access.redhat.com/openshift3/ose:v3.4.0.40 image ... OK
-- Checking Docker daemon configuration ... OK
-- Checking for available ports ... OK
-- Checking type of volume mount ...
   Using Docker shared volumes for OpenShift volumes
-- Creating host directories ... OK
-- Finding server IP ...
   Using 10.0.75.2 as the server IP
-- Starting OpenShift container ...
   Creating initial OpenShift configuration
FAIL
   Error: could not update OpenShift configuration
   Caused By:
     Error: API error (404): {"message":"lstat /var/lib/docker/overlay2/dd60566cac745dd8cd4008b3aef5b3f0cc327b8f812795894fcd46b99fbe7b6b/merged/\\var\\lib\\origin\\openshift.local.config\\master: no such file or directory"}


OR

oc cluster up
-- Checking OpenShift client ... OK
-- Checking Docker client ... OK
-- Checking Docker version ... OK
-- Checking for existing OpenShift container ... OK
-- Checking for registry.access.redhat.com/openshift3/ose:v3.4.0.40 image ... OK
-- Checking Docker daemon configuration ... OK
-- Checking for available ports ... OK
-- Checking type of volume mount ...
   Using Docker shared volumes for OpenShift volumes
-- Creating host directories ... OK
-- Finding server IP ...
   Using 10.0.75.2 as the server IP
-- Starting OpenShift container ...
   Creating initial OpenShift configuration
FAIL
   Error: could not update OpenShift configuration
   Caused By:
     Error: API error (404): {"message":"lstat /var/lib/docker/overlay2/b167f672e8684c7c83f04d00666695cf63028f9ce0c0c7190948caa7e05450a2/merged/\\var\\lib\\origin\\openshift.local.config\\master: no such file or directory"}


Expected results:

cluster starts up

Additional info:

seems to be related to this origin issue
https://github.com/openshift/origin/issues/11606
Did the fix come through into oc client 3.4

Comment 1 Cesar Wong 2017-01-30 15:51:18 UTC
A fix has been delivered to OSE with:
https://github.com/openshift/ose/pull/562

It should be part of OCP v3.4.1

Comment 2 Veer Muchandi 2017-01-30 16:02:12 UTC
@Cesar, When is OCP v3.4.1 available? Is it a change only to OCP or OC client as well?

(In reply to Cesar Wong from comment #1)
> A fix has been delivered to OSE with:
> https://github.com/openshift/ose/pull/562
> 
> It should be part of OCP v3.4.1

Comment 3 Cesar Wong 2017-01-30 16:07:21 UTC
@Veer, I'm not sure when 3.4.1 will be available. Scott may be able to tell you.

The fix did go into v1.4.1 of Origin as well:
https://github.com/openshift/origin/pull/12634

Comment 4 Veer Muchandi 2017-01-30 16:13:32 UTC
@Cesar, Another aspect that I am not understanding. The "oc cluster up --image=registry.access.redhat.com/openshift3/ose --version=3.4.0.40" works ok when I try with oc client v3.3.1.7

So is this a fix to client or OCP?

Comment 5 Cesar Wong 2017-01-30 16:14:34 UTC
@Veer it's a fix to the client in OCP

Comment 6 Veer Muchandi 2017-01-30 17:42:34 UTC
@Cesar, thanks.

Oc origin client v 1.4.1 works without this issue.

Comment 7 Dongbo Yan 2017-02-04 12:09:56 UTC
Verified

oc v3.4.1.2
kubernetes v1.4.0+776c994
features: Basic-Auth GSSAPI Kerberos SPNEGO

$ oc cluster up  --host-config-dir=xxxx

Comment 8 Scott Dodson 2017-02-06 15:34:34 UTC
v3.4.1.2 shipped last week so marking this CLOSED CURRENTRELEASE


Note You need to log in before you can comment on or make changes to this bug.