Bug 1417466 - Prevent reverse heal from happening
Summary: Prevent reverse heal from happening
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: replicate
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1422942 1429312
TreeView+ depends on / blocked
 
Reported: 2017-01-29 16:21 UTC by Pranith Kumar K
Modified: 2017-05-30 18:40 UTC (History)
1 user (show)

Fixed In Version: glusterfs-3.11.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1422942 1429312 (view as bug list)
Environment:
Last Closed: 2017-05-30 18:40:10 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Pranith Kumar K 2017-01-29 16:21:02 UTC
Description of problem:
There is a chance for the source brick to go down just after
the new entry is created and before source brick is marked with
necessary pending markers. If after this any I/O happens then
new entry will become source and reverse heal will happen.
To prevent this mark the pending xattrs before creating the new
entry.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Worker Ant 2017-01-29 16:25:49 UTC
REVIEW: https://review.gluster.org/16474 (cluster/afr: Perform new entry mark before creating new entry) posted (#1) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

Comment 2 Worker Ant 2017-02-14 17:19:07 UTC
REVIEW: https://review.gluster.org/16474 (cluster/afr: Perform new entry mark before creating new entry) posted (#2) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

Comment 3 Worker Ant 2017-02-16 15:24:34 UTC
COMMIT: https://review.gluster.org/16474 committed in master by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit 6588204568ab73bf8456ca3b2eccf2ae1182fb95
Author: Pranith Kumar K <pkarampu@redhat.com>
Date:   Mon Jan 23 14:58:45 2017 +0530

    cluster/afr: Perform new entry mark before creating new entry
    
    There is a chance for the source brick to go down just after
    the new entry is created and before source brick is marked with
    necessary pending markers. If after this any I/O happens then
    new entry will become source and reverse heal will happen.
    To prevent this mark the pending xattrs before creating the new
    entry.
    
    BUG: 1417466
    Change-Id: I233b87e694d32e5d734df5a83b4d2ca711c17503
    Signed-off-by: Pranith Kumar K <pkarampu@redhat.com>
    Reviewed-on: https://review.gluster.org/16474
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Ravishankar N <ravishankar@redhat.com>
    Reviewed-by: Krutika Dhananjay <kdhananj@redhat.com>

Comment 4 Shyamsundar 2017-05-30 18:40:10 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.11.0, please open a new bug report.

glusterfs-3.11.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2017-May/000073.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.