Bug 1417488 - system-config-samba , request to add in FC25
Summary: system-config-samba , request to add in FC25
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-samba
Version: 25
Hardware: All
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Nils Philippsen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-29 20:24 UTC by basilicum
Modified: 2017-02-03 17:30 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-03 17:30:52 UTC
Type: Bug


Attachments (Terms of Use)

Description basilicum 2017-01-29 20:24:37 UTC
Description of problem: 

For configuration of samba server in simple home networks system-config-samba is a perfect tool. At data it was dropped from FC25. 

Kind request to add system-config-samba again to Fedora, as there is no alternative for simple home networks. Alternatively a similar tool might be added. 

Because a tool for simple setups is missing use-ability of Fedora is hampered.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Nils Philippsen 2017-02-03 17:30:52 UTC
(In reply to basilicum from comment #0)
> For configuration of samba server in simple home networks
> system-config-samba is a perfect tool.

I know, right? ;)

Unfortunately I don't have the time to maintain the package anymore, let alone continue its development and have announced this to the Fedora Developers Mailing List last August:

https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/message/BIV6Z2LN2LCO4I6LE636PPWOINUETV3S/

Unfortunately nobody stepped up to take over, so I've retired it.

If you are willing to maintain the package, I'll gladly help you getting it unretired. The process is outlined here:

https://fedoraproject.org/wiki/Orphaned_package_that_need_new_maintainers#Claiming_Ownership_of_a_Retired_Package

But be warned, the codebase is pretty old and the upstream project is dead because my priorities lie elsewhere now.

In my opinion it is probably much more worthwhile to write a Samba Plugin for Cockpit (which is what largely replaced system-config tools in Fedora). There's an upstream issue for it, and while its not on the roadmap for the upstream developers to implement it themselves, they indicated that they'd be willing to at least help with the designs if not the code:

https://github.com/cockpit-project/cockpit/issues/3534

If you want to work on getting a useable Samba configuration tool back into Fedora, this is where I'd attempt scratching the itch.


Note You need to log in before you can comment on or make changes to this bug.