Bug 1417542 - Dnf won't synchronize cache
Summary: Dnf won't synchronize cache
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
(Show other bugs)
Version: 24
Hardware: Unspecified Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: rpm-software-management
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: EasyFix, Triaged
: 1417541 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-30 08:10 UTC by Martin Hatina
Modified: 2017-04-01 17:22 UTC (History)
4 users (show)

Fixed In Version: dnf-2.2.0-1.fc26
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-04-01 17:22:01 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
std-out (391 bytes, text/plain)
2017-01-30 08:11 UTC, Martin Hatina
no flags Details
std-err (53 bytes, text/plain)
2017-01-30 08:11 UTC, Martin Hatina
no flags Details
fedora-updates.repo (1.24 KB, text/plain)
2017-01-30 08:12 UTC, Martin Hatina
no flags Details
librepo.log (13.81 KB, text/plain)
2017-01-30 08:31 UTC, Martin Hatina
no flags Details
fedora.repo (1.22 KB, text/plain)
2017-01-30 09:28 UTC, Martin Hatina
no flags Details

Description Martin Hatina 2017-01-30 08:10:07 UTC
Description of problem:
Dnf won't synchronize cache when using --installroot

Version-Release number of selected component (if applicable):
dnf-2.0.0_1-76g9aae056.fc24.noarch

How reproducible:
always

Steps to Reproduce:
1. dnf --installroot=/home/mhatina/tmp install dnf -v

Actual results:
Error: Failed to synchronize cache for repo 'fedora'

Expected results:
dnf is installed in installroot

Comment 1 Martin Hatina 2017-01-30 08:11 UTC
Created attachment 1245760 [details]
std-out

Comment 2 Martin Hatina 2017-01-30 08:11 UTC
Created attachment 1245761 [details]
std-err

Comment 3 Martin Hatina 2017-01-30 08:12 UTC
Created attachment 1245762 [details]
fedora-updates.repo

Comment 4 Martin Hatina 2017-01-30 08:14:34 UTC
*** Bug 1417541 has been marked as a duplicate of this bug. ***

Comment 5 Igor Gnatenko 2017-01-30 08:19:06 UTC
librepo.log?

Comment 6 Martin Hatina 2017-01-30 08:31 UTC
Created attachment 1245775 [details]
librepo.log

Comment 7 Igor Gnatenko 2017-01-30 08:36:50 UTC
09:30:08 check_transfer_statuses: Transfer finished: https://mirrors.fedoraproject.org/metalink?repo=fedora-$releasever&arch=x86_64 (Effective url: https://mirrors.fedoraproject.org/metalink?repo=fedora-$releasever&arch=x86_64)


Seems like $releasever is not expanded...

Comment 8 Martin Hatina 2017-01-30 09:28 UTC
Created attachment 1245803 [details]
fedora.repo

Comment 9 Martin Hatina 2017-02-02 09:48:47 UTC
Fixed by https://github.com/rpm-software-management/dnf/pull/722

Comment 10 Fedora Update System 2017-03-21 12:08:00 UTC
dnf-2.1.1-1.fc26 libdnf-0.8.0-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-65586fa42b

Comment 11 Fedora Update System 2017-03-21 14:27:19 UTC
dnf-2.1.1-1.1.fc26, libdnf-0.8.0-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-65586fa42b

Comment 12 Fedora Update System 2017-03-27 19:20:52 UTC
dnf-2.2.0-1.fc26, libdnf-0.8.0-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-65586fa42b

Comment 13 Fedora Update System 2017-04-01 17:22:01 UTC
dnf-2.2.0-1.fc26, libdnf-0.8.0-1.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.