Bug 1417545 - Unable to set global volume options using 'all' as volume name
Summary: Unable to set global volume options using 'all' as volume name
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Gluster
Version: 4.1.0
Hardware: x86_64
OS: Linux
medium
high
Target Milestone: ovirt-4.4.0
: 4.4.0
Assignee: Kaustav Majumder
QA Contact: SATHEESARAN
URL:
Whiteboard:
Depends On:
Blocks: 1775586
TreeView+ depends on / blocked
 
Reported: 2017-01-30 08:44 UTC by SATHEESARAN
Modified: 2020-08-05 06:09 UTC (History)
4 users (show)

Fixed In Version: vdsm-4.40.14 ovirt-engine-4.4.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1775586 (view as bug list)
Environment:
Last Closed: 2020-08-05 06:09:51 UTC
oVirt Team: Gluster
pm-rhel: ovirt-4.4?
sasundar: planning_ack?
godas: devel_ack+
sasundar: testing_ack+


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 95636 0 'None' MERGED gluster: Added verb for getting global volume options. 2020-11-10 08:02:30 UTC
oVirt gerrit 105527 0 master MERGED gluster: Enable setting of global volume options 2020-11-10 08:02:30 UTC

Description SATHEESARAN 2017-01-30 08:44:05 UTC
Description of problem:
-----------------------
Some gluster volume options are set globally using the volume name as 'all'.
Such options couldn't be set from oVirt UI, as setting the volume options are always related to specific volume

Version-Release number of selected component (if applicable):
-------------------------------------------------------------
oVirt Engine Version: 4.1.0.3-0.0

How reproducible:
-----------------
Always

Steps to Reproduce:
-------------------
1. Try enabling 'cluster.enable_shared_storage' on a volume

Actual results:
---------------
'cluster.enable_shared_storage' is a global option. So unable to set this option on a single volume

Expected results:
-----------------
If the global options are invoked, then the volume name is chosen as 'all' 
or provide a way to set global options on all the volumes

Comment 1 Sahina Bose 2017-02-27 07:07:15 UTC
Needed to bump-up op-code version on upgrades as well as setting shared-storage option for geo-replication

Comment 2 Sandro Bonazzola 2019-01-28 09:34:12 UTC
This bug has not been marked as blocker for oVirt 4.3.0.
Since we are releasing it tomorrow, January 29th, this bug has been re-targeted to 4.3.1.

Comment 3 SATHEESARAN 2020-07-16 11:15:15 UTC
Tested with RHVH 4.4.1 and RHGS 3.5.2-async

Able to set the global volume option from RHV Manager UI : Storage > Select volume > Select volume options > Add

Comment 4 Sandro Bonazzola 2020-08-05 06:09:51 UTC
This bugzilla is included in oVirt 4.4.0 release, published on May 20th 2020.

Since the problem described in this bug report should be
resolved in oVirt 4.4.0 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.