Bug 1417596 - [GDEPLOY] Gdeploy --version throws Error: Package PyYAML not found on Rhel6
Summary: [GDEPLOY] Gdeploy --version throws Error: Package PyYAML not found on Rhel6
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: gdeploy
Version: rhgs-3.2
Hardware: Unspecified
OS: Unspecified
medium
unspecified
Target Milestone: ---
: RHGS 3.3.0
Assignee: Sachidananda Urs
QA Contact: Manisha Saini
URL:
Whiteboard:
Depends On:
Blocks: 1417147
TreeView+ depends on / blocked
 
Reported: 2017-01-30 11:39 UTC by Manisha Saini
Modified: 2017-09-21 04:17 UTC (History)
11 users (show)

Fixed In Version: gdeploy-2.0.1-2
Doc Type: Bug Fix
Doc Text:
Previously, checking for the gdeploy version would end up exiting if PyYAML package was not installed. Now PyYAML package check is not done for commands like --version or -- help.
Clone Of:
Environment:
Last Closed: 2017-09-21 04:17:38 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2776 normal SHIPPED_LIVE gdeploy bug fix and enhancement update for RHEL6 2017-09-21 08:16:15 UTC

Description Manisha Saini 2017-01-30 11:39:56 UTC
Description of problem:
Displaying Gdeploy --version throws Error: Package PyYAML not found on Rhel6

Version-Release number of selected component (if applicable):
# rpm -qa | grep gdeploy
gdeploy-2.0.1-8.el6rhs.noarch


How reproducible:
Consistently

Steps to Reproduce:
1.Install Gdeploy on Rhel 6
2.Check Gdeploy Version

# gdeploy --version
Error: Package PyYAML not found.



Actual results:
Version is not displayed due to PyYAML package missing


Expected results:
All Dependent Packages should be installed during gdeploy installation

Additional info:

Comment 2 Manisha Saini 2017-01-30 12:13:32 UTC
The workaround for this is-

Install PyYAML package seperately which is available in rhel-6-server-rpms repo.

Comment 4 Sachidananda Urs 2017-02-17 07:11:13 UTC
This is due to the missing dependency in the build spec file. Build spec file incorporated changes from: https://github.com/gluster/gdeploy/commit/6d31d9a

Comment 7 Manisha Saini 2017-04-14 08:11:14 UTC
Verified this bug on

# rpm -qa | grep gdeploy
gdeploy-2.0.2-3.el6rhs.noarch


# gdeploy  --version
Error: Ansible(>= 2.2) is not installed.
Some of the features might not work if not installed.

gdeploy 2.0.2

Installing:
 gdeploy                    noarch              2.0.2-3.el6rhs              
/gdeploy-2.0.2-3.el6rhs.noarch              2.5 M
Installing for dependencies:
 PyYAML                     x86_64              3.10-3.1.el6                
RH-6.9-Server                               157 k
 libyaml                    x86_64              0.1.3-4.el6_6                
RH-6.9-Server                                52 k
 python-babel               noarch              0.9.4-5.1.el6                
RH-6.9-Server                               1.4 M
 python-jinja2              x86_64              2.2.1-3.el6                  
RH-6.9-optional                             466 k


PyYAML package is now pulled in as dependent package while installing gdeply.
Moving this bug to verified state

Comment 12 errata-xmlrpc 2017-09-21 04:17:38 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2776


Note You need to log in before you can comment on or make changes to this bug.