Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1417632 - [hypervisor] upgrade_check fails if there's no repo to satisfy ovirt-node-ng-image-update
Summary: [hypervisor] upgrade_check fails if there's no repo to satisfy ovirt-node-ng-...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: Host-Deploy
Version: 4.1.0.2
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: ---
Assignee: Moti Asayag
QA Contact: Pavel Stehlik
URL: http://www.ovirt.org/develop/release-...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-30 13:23 UTC by Jiri Belka
Modified: 2017-02-07 06:59 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-07 06:59:43 UTC
oVirt Team: Infra


Attachments (Terms of Use)

Description Jiri Belka 2017-01-30 13:23:33 UTC
Description of problem:

(Originally as comment at https://bugzilla.redhat.com/show_bug.cgi?id=1381419#c5)

when no repo has a rpm with has in rpm metadata 'provides: ovirt-node-ng-image-update' the upgradecheck fails with:

~~~
Failed to check for available updates on host dell-r210ii-03 with message 'Command returned failure code 1 during SSH session 'root@10.34.63.222''.
~~~

IMO isn't the issue here?

~~~
 Yum: queue package ovirt-node-ng-image-update for install
~~~

Wouldn't be better to get 'yum list updates' equivalent via python module and parse output? This way it won't fail with rc 1. Just guessing loudly...

2017-01-27 12:28:51 DEBUG otopi.context context._executeMethod:128 Stage packages METHOD otopi.plugins.ovirt_host_mgmt.packages.update.Plugin._packagesCheck
2017-01-27 12:28:51 DEBUG otopi.plugins.ovirt_host_mgmt.packages.update update.verbose:94 Yum: queue package ovirt-node-ng-image-update for install
2017-01-27 12:28:51 ERROR otopi.plugins.ovirt_host_mgmt.packages.update update.error:102 Yum: Cannot queue package ovirt-node-ng-image-update: Package ovirt-node-ng-image-update cannot be found
2017-01-27 12:28:51 INFO otopi.plugins.ovirt_host_mgmt.packages.update update.info:98 Yum: Performing yum transaction rollback
2017-01-27 12:28:51 DEBUG otopi.context context._executeMethod:142 method exception
Traceback (most recent call last):
  File "/tmp/ovirt-7pEBIyFC1u/pythonlib/otopi/context.py", line 132, in _executeMethod
    method['method']()
  File "/tmp/ovirt-7pEBIyFC1u/otopi-plugins/ovirt-host-mgmt/packages/update.py", line 110, in _packagesCheck
    packages=self.environment[omgmt.PackagesEnv.PACKAGES],
  File "/tmp/ovirt-7pEBIyFC1u/pythonlib/otopi/miniyum.py", line 851, in install
    **kwargs
  File "/tmp/ovirt-7pEBIyFC1u/pythonlib/otopi/miniyum.py", line 500, in _queue
    package=package,
RuntimeError: Package ovirt-node-ng-image-update cannot be found
2017-01-27 12:28:51 ERROR otopi.context context._executeMethod:151 Failed to execute stage 'Package installation': Package ovirt-node-ng-image-update cannot be found
2017-01-27 12:28:51 DEBUG otopi.transaction transaction.abort:119 aborting 'Yum Transaction'
2017-01-27 12:28:51 INFO otopi.plugins.otopi.packagers.yumpackager yumpackager.info:80 Yum Performing yum transaction rollback
Loaded plugins: product-id
2017-01-27 12:28:51 DEBUG otopi.context context.dumpEnvironment:760 ENVIRONMENT DUMP - BEGIN
2017-01-27 12:28:51 DEBUG otopi.context context.dumpEnvironment:770 ENV BASE/error=bool:'True'
2017-01-27 12:28:51 DEBUG otopi.context context.dumpEnvironment:770 ENV BASE/exceptionInfo=list:'[(<type 'exceptions.RuntimeError'>, RuntimeError('Package ovirt-node-ng-image-update cannot be found',), <traceback object at 0x1c3b1b8>)]'
2017-01-27 12:28:51 DEBUG otopi.context context.dumpEnvironment:774 ENVIRONMENT DUMP - END

Version-Release number of selected component (if applicable):
ovirt-engine-4.1.0.2-0.2.el7.noarch

How reproducible:
100%

Steps to Reproduce:
1. install hypervisor (ngn)
2. do not have defined repos for ovirt-node-ng-image-update package
3. run upgrade check of host

Actual results:
Failed to check for available updates on host dell-r210ii-03 with message 'Command returned failure code 1 during SSH session 'root@10.34.63.222''.

Expected results:
something more understandable

Additional info:

Comment 1 Sandro Bonazzola 2017-01-30 14:53:32 UTC
Moving to Moti since he's the owner of the upgrade management feature.

Comment 2 Martin Perina 2017-01-31 09:49:32 UTC
So we could ignore errors that package doesn't exists during check for upgrade, but I don't want to do that for following reasons:

1. This warns admin that something is wrong with his setup, because all repositories should be available (there might be network/mirrors issues, but generally you shouldn't get into the package unknown issue).

2. This is the only way for admin how to find out that he entered wrong package name into UserPackageNamesForCheckUpdate option via engine-config

I'd probably close it as WONTFIX if there are no strong opinions otherwise ...

Comment 3 Martin Perina 2017-02-07 06:59:43 UTC
Closing as WONTFIX, feel free to reopen and provide new reasons why this should be fixed


Note You need to log in before you can comment on or make changes to this bug.