Bug 1417641 - [RFE] NetworkCheck oc adm diagnostic command for offline environments
Summary: [RFE] NetworkCheck oc adm diagnostic command for offline environments
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: RFE
Version: 3.4.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: ---
Assignee: Ravi Sankar
QA Contact: Meng Bo
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-30 13:42 UTC by Javier Ramirez
Modified: 2018-03-12 13:54 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-03-12 13:54:36 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Origin (Github) 14364 0 None None None 2017-05-26 19:03:26 UTC

Description Javier Ramirez 2017-01-30 13:42:32 UTC
Description of problem:
When running the NetworkCheck diagnostic on onffline environments , it fails when trying to pull a docker image from docker.io

Version-Release number of selected component (if applicable):
3.4.0

How reproducible:
Alawys

Steps to Reproduce:
1.oc adm diagnostics NetworkCheck --diaglevel=0 

Actual results:
network-diag-ns-s1raa   2017-01-27 12:51:50 +0100 CET   2017-01-27 12:51:50 +0100 CET   1         network-diag-test-pod-k3kwl   Pod       spec.containers{network-diag-test-pod-k3kwl}   Normal    Pulling   {kubelet siy05ez4}   pulling image "docker.io/openshift/hello-openshift"
network-diag-ns-s1raa   2017-01-27 12:51:50 +0100 CET   2017-01-27 12:51:50 +0100 CET   1         network-diag-test-pod-k3kwl   Pod       spec.containers{network-diag-test-pod-k3kwl}   Warning   Failed    {kubelet siy05ez4}   Failed to pull image "docker.io/openshift/hello-openshift": image pull failed for docker.io/openshift/hello-openshift:latest, this may be because there are no credentials on this request.  details: (All endpoints blocked.)
network-diag-ns-s1raa   2017-01-27 12:51:50 +0100 CET   2017-01-27 12:51:50 +0100 CET   1         network-diag-test-pod-k3kwl   Pod                 Warning   FailedSync   {kubelet siy05ez4}   Error syncing pod, skipping: failed to "StartContainer" for "network-diag-test-pod-k3kwl" with ErrImagePull: "image pull failed for docker.io/openshift/hello-openshift:latest, this may be because there are no credentials on this request.  details: (All endpoints blocked.)"

Expected results:
Provide a way to get the necessary image from an internal registry

Additional info:

Comment 3 Ravi Sankar 2017-05-25 20:13:48 UTC
Fix https://github.com/openshift/origin/pull/14364 (pending review/merge) will allow network diagnostic test pod to be passed as config option. This could be useful in offline environments.

Comment 5 openshift-github-bot 2017-05-31 23:08:00 UTC
Commit pushed to master at https://github.com/openshift/origin

https://github.com/openshift/origin/commit/66ff46e9cffd427246247290433022906572f4fb
Bug 1417641 - Make network diagnostic test pod image/protocol/port configurable

This will be helpful in offline environments.

Comment 6 Eric Rich 2018-03-12 13:54:36 UTC
This bug has been identified as a dated (created more than 3 months ago) bug. 
This bug has been triaged (has a trello card linked to it), or reviewed by Engineering/PM and has been put into the product backlog, 
however this bug has not been slated for a currently planned release (3.9, 3.10 or 3.11), which cover our releases for the rest of the calendar year. 

As a result of this bugs age, state on the current roadmap and PM Score (being below 70), this bug is being Closed - Differed, 
as it is currently not part of the products immediate priorities.

Please see: https://docs.google.com/document/d/1zdqF4rB3ea8GmVIZ7qWCVYUaQ7-EexUrQEF0MTwdDkw/edit for more details.


Note You need to log in before you can comment on or make changes to this bug.