Bug 1417667 - Kernel Panic at beginning of boot: No entropy gathering module detected
Summary: Kernel Panic at beginning of boot: No entropy gathering module detected
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: dracut
Version: 25
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: dracut-maint-list
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-30 15:41 UTC by sedrubal
Modified: 2019-01-09 12:54 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-02 01:30:37 UTC
Type: Bug


Attachments (Terms of Use)
The Kernel Panic Output (441.50 KB, image/png)
2017-01-30 16:41 UTC, sedrubal
no flags Details

Description sedrubal 2017-01-30 15:41:08 UTC
Description of problem:
Right at the beginning of the boot there is a kernel panic (with 4.9.x kernels).

Version-Release number of selected component (if applicable):
- kernel-4.9.4-201.fc25.x86_64
- kernel-4.9.5-200.fc25.x86_64

- not affected: kernel-4.8.16-300.fc25.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Reboot System
2. Boot one of the named kernels above

Actual results:
Kernel Panic

Expected results:
There shouldn't be a kernel panic.

Additional info:
will add info soon...

My setup:
- Acer Aspire V3 771G
- Intel(R) Core(TM) i5-3210M CPU
- EFI
- Grub2
- /boot/ is located on subvilume root in btrfs in luks encrypted volume

Comment 1 sedrubal 2017-01-30 16:21:07 UTC
I also use dracut-044-78.fc25.x86_64.

Update:

After running re generating the initramfs (`dracut -f`) this also happens with kernel-4.8.16-300.fc25.x86_64. So it looks to be a dracut problem...

Comment 2 sedrubal 2017-01-30 16:41:32 UTC
Created attachment 1245924 [details]
The Kernel Panic Output

Fatal: no entropy gathering module detected
traps: init[1] general protection ip:... in libc-2.24.so
Kernel panic - not syncing: Attempted to kill init! exitcode=0x0b

Comment 3 Laura Abbott 2017-02-01 17:05:35 UTC
This is a dracut issue, not an actual kernel issue. Do you have dracut-fips installed? If so, please remove and rebuild your initramfs

Comment 4 sedrubal 2017-02-02 01:30:37 UTC
Thanks Laura for your response and pointing me in the right direction.

Uninstalling dracut-fips solved the problem.

So did I understand it correctly that I need hardware entropy generators for FIPS? So this isn't a bug at all because I think there is no such thing in my pc (accessing /dev/hwrng says "No such device" and there is no tpm)...

Is dracut-fips included in a standard installation or did I install it recently? :D


Note You need to log in before you can comment on or make changes to this bug.