Bug 1417674 - [dev-preview-stg] dancer-mysql-persistent build fail
Summary: [dev-preview-stg] dancer-mysql-persistent build fail
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: OpenShift Online
Classification: Red Hat
Component: Build
Version: 3.x
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
: ---
Assignee: Corey Daley
QA Contact: Wang Haoran
URL:
Whiteboard: online_3.4.1
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-30 15:57 UTC by Mike Fiedler
Modified: 2017-01-31 15:08 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-31 15:08:36 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Mike Fiedler 2017-01-30 15:57:36 UTC
Description of problem:

Testing 3.4.1.2, the dancer-mysql-persistent quickstart fails to build every time.   See below for log.


Version-Release number of selected component (if applicable): 3.4.1.2


How reproducible: Always


Steps to Reproduce:
1.  From web ui, create new dancer-mysql-persistent application
2.  Watch the build - it will fail with errors below


Actual results:

gzip: stdin: unexpected end of file
/usr/bin/tar: Child returned status 1
/usr/bin/tar: Error is not recoverable: exiting now
! Failed to unpack Module-CoreList-5.20170120.tar.gz: no directory
! Failed to fetch distribution Module-CoreList-5.20170120

error: build error: non-zero (13) exit code from registry.access.redhat.com/rhscl/perl-520-rhel7@sha256:b7e2224696b2edf558488bc96b2da855b5fa77f726e974fba2600af2c2e7162b

Expected results:

Successful build

Additional info:

Pulling image "registry.access.redhat.com/rhscl/perl-520-rhel7@sha256:b7e2224696b2edf558488bc96b2da855b5fa77f726e974fba2600af2c2e7162b" ...
Pulling image "registry.access.redhat.com/rhscl/perl-520-rhel7@sha256:b7e2224696b2edf558488bc96b2da855b5fa77f726e974fba2600af2c2e7162b" ...
Cloning "https://github.com/openshift/dancer-ex.git" ...
	Commit:	77a4563f408c8fc1a4917e5e4f9b4c34cc615e33 (Merge pull request #58 from coreydaley/update_templates_to_use_secrets_2)
	Author:	Ben Parees <bparees@users.noreply.github.com>
	Date:	Wed Jan 18 14:07:19 2017 -0500

---> Installing application source ...
---> Copying configuration files...
'./cfg/dancer.conf' -> '/opt/app-root/etc/httpd.d/dancer.conf'
---> Installing cpanminus 1.7102 ...
!
! Can't write to /opt/rh/rh-perl520/root/usr/local/share/perl5 and /opt/rh/rh-perl520/root/usr/local/bin: Installing modules to /opt/app-root/src/perl5
! To turn off this warning, you have to do one of the following:
!   - run me as a root or with --sudo option (to install to /opt/rh/rh-perl520/root/usr/local/share/perl5 and /opt/rh/rh-perl520/root/usr/local/bin)
!   - Configure local::lib your existing local::lib in this shell to set PERL_MM_OPT etc.
!   - Install local::lib by running the following commands
!
!         cpanm --local-lib=~/perl5 local::lib && eval $(perl -I ~/perl5/lib/perl5/ -Mlocal::lib)
!
--> Working on App::cpanminus
Fetching http://www.cpan.org/authors/id/M/MI/MIYAGAWA/App-cpanminus-1.7042.tar.gz ... OK
Configuring App-cpanminus-1.7042 ... OK
==> Found dependencies: Test::More
--> Working on Test::More
Fetching http://www.cpan.org/authors/id/E/EX/EXODIST/Test-Simple-1.302075.tar.gz ... OK
Configuring Test-Simple-1.302075 ... OK
Building and testing Test-Simple-1.302075 ... OK
Successfully installed Test-Simple-1.302075
Building and testing App-cpanminus-1.7042 ... OK
Successfully installed App-cpanminus-1.7042
2 distributions installed
---> Installing modules from cpanfile ...
--> Working on Module::CoreList
Fetching http://www.cpan.org/authors/id/B/BI/BINGOS/Module-CoreList-5.20170120.tar.gz ... OK

gzip: stdin: unexpected end of file
/usr/bin/tar: Child returned status 1
/usr/bin/tar: Error is not recoverable: exiting now
! Failed to unpack Module-CoreList-5.20170120.tar.gz: no directory
! Failed to fetch distribution Module-CoreList-5.20170120

error: build error: non-zero (13) exit code from registry.access.redhat.com/rhscl/perl-520-rhel7@sha256:b7e2224696b2edf558488bc96b2da855b5fa77f726e974fba2600af2c2e7162b

Comment 1 Corey Daley 2017-01-30 17:08:16 UTC
It looks like this is an issue with cpan.org/cpan.org mirrors, you can get the same "not found" errors by trying to wget the module manually:

wget http://www.cpan.org/authors/id/B/BI/BINGOS/Module-CoreList-5.20170120.tar.gz

or by running the cpanm command locally:

cpanm  -l extlib Module::CoreList -v

If this is a mirror issue it could be intermittent or region based depending on what mirror you connect to.  Also, the file seems to download correctly if you put the url into a browser, but not via command line (wget, cpanm, etc)

Comment 2 Corey Daley 2017-01-30 18:16:48 UTC
I am now able to run the build successfully.  I will continue to monitor throughout the day and if no further issues are seen I will close this bug report.

Comment 3 Corey Daley 2017-01-31 14:50:09 UTC
This is still working today, it looks like cpan fixed their issue.

Comment 4 Mike Fiedler 2017-01-31 15:08:36 UTC
 Working for me today.  No OpenShift change, marking WORKSFORME


Note You need to log in before you can comment on or make changes to this bug.