Bug 1417691 - FTBFS: inkscape-0.92.0-12.fc26
Summary: FTBFS: inkscape-0.92.0-12.fc26
Keywords:
Status: CLOSED DUPLICATE of bug 1423740
Alias: None
Product: Fedora
Classification: Fedora
Component: inkscape
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Gwyn Ciesla
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-30 16:50 UTC by Jonathan Wakely
Modified: 2017-02-23 19:32 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-23 19:32:02 UTC
Type: Bug


Attachments (Terms of Use)
build.log from scratch build (3.95 MB, text/plain)
2017-01-30 16:50 UTC, Jonathan Wakely
no flags Details

Description Jonathan Wakely 2017-01-30 16:50:12 UTC
Created attachment 1245929 [details]
build.log from scratch build

ui/tools/flood-tool.cpp: In function 'bool Inkscape::UI::Tools::compare_pixels(guint32, guint32, guint32, guint32, int, Inkscape::UI::Tools::PaintBucketChannels)':
ui/tools/flood-tool.cpp:235:49: error: call of overloaded 'abs(guint32)' is ambiguous
             return abs(static_cast<int>(ac) - ao) <= threshold;
                                                 ^

This is due to a change in GCC 7's C++ headers which makes more overloads of std::abs visible, and so calls with an unsigned argument type are ill-formed in more cases than for GCC 6 (see https://gcc.gnu.org/gcc-6/porting_to.html#overloaded-abs notes for more info).

In the code above the expression does abs((int)ac - (unsigned)ao), and the result of that is unsigned.

Presumably the intention was abs((int)ac - (int)ao), in which case another cast is needed, but I'm not going to second guess the authors.

Comment 1 Jonathan Wakely 2017-02-17 02:47:53 UTC
Failed in the mass rebuild: https://koji.fedoraproject.org/koji/taskinfo?taskID=17740931

Comment 2 Gwyn Ciesla 2017-02-23 19:32:02 UTC

*** This bug has been marked as a duplicate of bug 1423740 ***


Note You need to log in before you can comment on or make changes to this bug.