Bug 1417697 - Unable start gnocchi-api service via systemd as a stand-alone service
Summary: Unable start gnocchi-api service via systemd as a stand-alone service
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-gnocchi
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: z2
: 10.0 (Newton)
Assignee: Pradeep Kilambi
QA Contact: Sasha Smolyak
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-30 16:57 UTC by Attila Fazekas
Modified: 2017-03-01 13:38 UTC (History)
6 users (show)

Fixed In Version: openstack-gnocchi-3.0.4-2.el7ost
Doc Type: Bug Fix
Doc Text:
Cause: gnocchi-api standalone script does not start correctly Consequence: Due to a bug in systemd service script, gnocchi api stand alone script fails to start. Though note that its recommended that gnocchi api is used under apache wsgi anyway. Fix: The service script has been fixed to ensure gnocchi api starts correctly at package install time. Result: service script for gnocchi api starts as expected without any errors.
Clone Of:
Environment:
Last Closed: 2017-03-01 13:38:46 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
RDO 5021 None None None 2017-02-08 19:06:29 UTC
RDO 5216 None None None 2017-02-13 19:17:29 UTC
Red Hat Product Errata RHBA-2017:0355 normal SHIPPED_LIVE Red Hat OpenStack Platform 10 Bug Fix and Enhancement Advisory 2017-03-01 18:33:11 UTC

Description Attila Fazekas 2017-01-30 16:57:08 UTC
Description of problem:
/usr/lib/systemd/system/openstack-gnocchi-api.service has the
ExecStart=/usr/bin/gnocchi-api --logfile /var/log/gnocchi/api.log .

openstack-gnocchi-api refuses the --logfile argument in this form.

Version-Release number of selected component (if applicable):
openstack-gnocchi-api-3.0.3-1.el7ost.noarch

How reproducible:
always

Actual results:
Jan 30 09:00:26 afazekas-1485784488.localdomain gnocchi-api[10133]: usage: gnocchi-api [-h] [--port PORT] -- [passed options]
Jan 30 09:00:26 afazekas-1485784488.localdomain gnocchi-api[10133]: gnocchi-api: error: unrecognized arguments: --logfile


Expected results:
systemctl start openstack-gnocchi-api.service
working .

Additional info:
/usr/bin/gnocchi-api -- --logfile /var/log/gnocchi/api.log seams to be working.

Looks like enough to add '--' to the service file, and the option is respected.

Comment 8 errata-xmlrpc 2017-03-01 13:38:46 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2017-0355.html


Note You need to log in before you can comment on or make changes to this bug.