Bug 1417701 - python-ipaddr issues with IPv6: AttributeError: 'module' object has no attribute 'Bytes'
Summary: python-ipaddr issues with IPv6: AttributeError: 'module' object has no attrib...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: python-ipaddr
Version: 7.3
Hardware: Unspecified
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: Charalampos Stratakis
QA Contact: Jan Kepler
URL:
Whiteboard:
: 1208811 1400694 (view as bug list)
Depends On:
Blocks: 1206380 1346768
TreeView+ depends on / blocked
 
Reported: 2017-01-30 17:07 UTC by Chandan Chouhan
Modified: 2020-09-10 10:10 UTC (History)
10 users (show)

Fixed In Version: python-ipaddr-2.1.11-1.el7
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2017-08-01 18:14:56 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1208811 None CLOSED AttributeError: 'module' object has no attribute 'Bytes' 2018-05-25 11:21:21 UTC
Red Hat Product Errata RHBA-2017:1925 normal SHIPPED_LIVE python-ipaddr bug fix update 2017-08-01 18:07:08 UTC

Description Chandan Chouhan 2017-01-30 17:07:38 UTC
Description of problem:

Apr  3 07:17:57 examplesrv policyd-spf[11516]: Traceback (most recent call last):
Apr  3 07:17:57 examplesrv policyd-spf[11516]: File "/usr/libexec/postfix/policyd-spf", line 680, in <module>
Apr  3 07:17:57 examplesrv policyd-spf[11516]: instance_dict, configData, peruser)
Apr  3 07:17:57 examplesrv policyd-spf[11516]: File "/usr/libexec/postfix/policyd-spf", line 517, in _spfcheck
Apr  3 07:17:57 examplesrv policyd-spf[11516]: res = spf.check2(ip, sender, helo, querytime=configData.get('Lookup_Time'))
Apr  3 07:17:57 examplesrv policyd-spf[11516]: File "/usr/lib/python2.7/site-packages/spf.py", line 297, in check2
Apr  3 07:17:57 examplesrv policyd-spf[11516]: receiver=receiver,timeout=timeout,verbose=verbose,querytime=querytime).check()
Apr  3 07:17:57 examplesrv policyd-spf[11516]: File "/usr/lib/python2.7/site-packages/spf.py", line 547, in check
Apr  3 07:17:57 examplesrv policyd-spf[11516]: rc = self.check1(spf, self.d, 0)
Apr  3 07:17:57 examplesrv policyd-spf[11516]: File "/usr/lib/python2.7/site-packages/spf.py", line 586, in check1
Apr  3 07:17:57 examplesrv policyd-spf[11516]: return self.check0(spf, recursion)
Apr  3 07:17:57 examplesrv policyd-spf[11516]: File "/usr/lib/python2.7/site-packages/spf.py", line 900, in check0
Apr  3 07:17:57 examplesrv policyd-spf[11516]: if self.cidrmatch(self.dns_mx(arg), cidrlength):
Apr  3 07:17:57 examplesrv policyd-spf[11516]: File "/usr/lib/python2.7/site-packages/spf.py", line 1194, in dns_mx
Apr  3 07:17:57 examplesrv policyd-spf[11516]: return [a for mx in mxnames[:max] for a in self.dns_a(mx[1],self.A)]
Apr  3 07:17:57 examplesrv policyd-spf[11516]: File "/usr/lib/python2.7/site-packages/spf.py", line 1206, in dns_a
Apr  3 07:17:57 examplesrv policyd-spf[11516]: return [ipaddress.Bytes(ip) for ip in r]
Apr  3 07:17:57 examplesrv policyd-spf[11516]: AttributeError: 'module' object has no attribute 'Bytes'


Version-Release number of selected component (if applicable):

python-ipaddr-2.1.9-5.el7.noarch

Comment 1 Robert Scheck 2017-01-30 17:28:07 UTC
Why is this version 7.5-Pegas rather 7.4? Could you adjust it, please?

Cross-filed case 01781715 on the Red Hat customer portal.

Comment 3 George Notaras 2017-01-31 19:09:29 UTC
*** Bug 1208811 has been marked as a duplicate of this bug. ***

Comment 7 Charalampos Stratakis 2017-02-08 11:58:08 UTC
*** Bug 1400694 has been marked as a duplicate of this bug. ***

Comment 9 Liam Middlebrook 2017-04-08 04:30:43 UTC
Hi, is there any estimate when this will be moved from QA to production?

Comment 10 Charalampos Stratakis 2017-04-10 09:08:02 UTC
(In reply to Liam Middlebrook from comment #9)
> Hi, is there any estimate when this will be moved from QA to production?

Hello Liam,

Unfortunately we cannot provide an estimate currently, of when this fix will be deployed to production.

Comment 11 Honza Horak 2017-04-11 07:45:57 UTC
Liam, it will be rather months than weeks, but feel free to contact the RH Customer Support for some better answer, because engineering is not able to provide such information. Thanks for understanding.

Comment 13 errata-xmlrpc 2017-08-01 18:14:56 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1925


Note You need to log in before you can comment on or make changes to this bug.