Bug 1417713 - [WA] Memory definition is not striped of white spaces
Summary: [WA] Memory definition is not striped of white spaces
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin
Version: 4.1.0.2
Hardware: All
OS: All
low
low vote
Target Milestone: ovirt-4.2.0
: 4.2.0
Assignee: jniederm
QA Contact: Lucie Leistnerova
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-30 17:48 UTC by Lukas Svaty
Modified: 2017-12-22 07:31 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2017-12-20 10:53:41 UTC
oVirt Team: Virt
rule-engine: ovirt-4.2+
rule-engine: planning_ack+
rule-engine: devel_ack+
lsvaty: testing_ack+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 71571 None None None 2017-02-07 14:28:53 UTC

Description Lukas Svaty 2017-01-30 17:48:42 UTC
Description of problem:
having memory being evaluated to MB does only work in specific format and does not strip white space characters in the end.

Version-Release number of selected component (if applicable):
ovirt-engine-webadmin-portal-4.1.0.2-0.1.el7.noarch

How reproducible:
100%

Steps to Reproduce:
1. Go to VMs -> Edit VM -> System Tab -> Memory -> add "1 GB " (with space in the end)
2. Tab to next field

Actual results:
0 MB

Expected results:
1024 MB

Comment 1 Lucie Leistnerova 2017-08-31 12:36:49 UTC
Memory evaluation works with spaces too.

verified in ovirt-engine-webadmin-portal-4.2.0-0.0.master.20170828065003.git0619c76.el7.centos.noarch

Comment 2 Sandro Bonazzola 2017-12-20 10:53:41 UTC
This bugzilla is included in oVirt 4.2.0 release, published on Dec 20th 2017.

Since the problem described in this bug report should be
resolved in oVirt 4.2.0 release, published on Dec 20th 2017, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.