Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1417723 - atomic-openshift-docker-excluder in 3.3 doesn't exclude docker-1.12
Summary: atomic-openshift-docker-excluder in 3.3 doesn't exclude docker-1.12
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.3.1
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 3.3.1
Assignee: Scott Dodson
QA Contact: Wenkai Shi
URL:
Whiteboard:
: 1425204 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-30 18:25 UTC by Alex Dellapenta
Modified: 2017-03-02 21:30 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously atomic-openshift-docker-excluder did not include docker-1.12 in its exclusions list. OCP 3.3 is not tested with docker-1.12 so that version has been added to the exclusion list to prevent its installation.
Clone Of:
Environment:
Last Closed: 2017-02-22 18:11:53 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:0289 0 normal SHIPPED_LIVE OpenShift Container Platform 3.4.1.7, 3.3.1.14, and 3.2.1.26 bug fix update 2017-02-22 23:10:04 UTC

Description Alex Dellapenta 2017-01-30 18:25:34 UTC
OCP 3.3 needs Docker 1.10 according to:

https://docs.openshift.com/container-platform/3.3/install_config/install/host_preparation.html#installing-docker

But atomic-openshift-docker-excluder in the 3.3 channel isn't excluding Docker 1.12:

https://github.com/openshift/ose/pull/467/files

This causes OCP 3.3 installs to be able to install/upgrade to Docker 1.12.

Comment 1 Scott Dodson 2017-01-30 18:27:13 UTC
https://github.com/openshift/ose/pull/589

Comment 3 Wenkai Shi 2017-02-04 10:11:26 UTC
Verified with version atomic-openshift-docker-excluder-3.3.1.12-1.git.0.3d14c02.el7.noarch. Docker 1.12 has been exclude. It can be checked on /etc/yum.conf. Docker can not be update to 1.12.

[root@openshift ~]# cat /etc/yum.conf
... 
exclude= docker*1.20*  docker*1.19*  docker*1.18*  docker*1.17*  docker*1.16*  docker*1.15*  docker*1.14*  docker*1.13*  docker*1.12*
...

[root@openshift ~]# rpm -q docker 
docker-1.10.3-59.el7.x86_64

[root@openshift ~]# yum search docker --show-dup
...
2:docker-1.10.3-59.el7.x86_64 : Automates deployment of containerized applications
2:docker-1.12.5-14.el7.x86_64 : Automates deployment of containerized applications
...

[root@openshift ~]# yum update docker 
...
No packages marked for update

Comment 5 errata-xmlrpc 2017-02-22 18:11:53 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:0289

Comment 6 Scott Dodson 2017-03-02 21:30:24 UTC
*** Bug 1425204 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.