Bug 1417764 - FTBFS: thrift
Summary: FTBFS: thrift
Keywords:
Status: CLOSED DUPLICATE of bug 1385702
Alias: None
Product: Fedora
Classification: Fedora
Component: thrift
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Will Benton
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-30 22:14 UTC by Jonathan Wakely
Modified: 2017-01-30 22:21 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-30 22:21:46 UTC
Type: Bug


Attachments (Terms of Use)

Description Jonathan Wakely 2017-01-30 22:14:41 UTC
A rawhide build fails with:

checking for clock_gettime in -lrt... yes
checking for setsockopt in -lsocket... no
checking for BN_init in -lcrypto... no
configure: error: "Error: libcrypto required."
RPM build errors:
error: Bad exit status from /var/tmp/rpm-tmp.y6ohOi (%build)
    Bad exit status from /var/tmp/rpm-tmp.y6ohOi (%build)


The configure test is not compatible with openssl-1.1.0 in rawhide, because it checks for BN_init:

| #ifdef __cplusplus
| extern "C"
| #endif
| char BN_init ();
| int
| main ()
| {
| return BN_init ();
|   ;
|   return 0;
| }
configure:21845: result: no
configure:21892: error: "Error: libcrypto required."

However in openssl-1.1.0 that function doesn't exist:

https://www.openssl.org/docs/man1.1.0/crypto/BN_new.html

Either it needs to be updated to work with openssl-1.1.0 or it needs to use compat-openssl instead.

Comment 1 Jonathan Wakely 2017-01-30 22:21:46 UTC

*** This bug has been marked as a duplicate of bug 1385702 ***


Note You need to log in before you can comment on or make changes to this bug.