Bug 1417768 - OpenAL library missing.
Summary: OpenAL library missing.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: visualboyadvance-m
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jeremy Newton
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-30 22:37 UTC by Andrew Toskin
Modified: 2017-02-09 20:50 UTC (History)
1 user (show)

Fixed In Version: visualboyadvance-m-2.0.0-0.9.Beta3.fc25 visualboyadvance-m-2.0.0-0.9.Beta3.fc24
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-09 04:21:58 UTC


Attachments (Terms of Use)

Description Andrew Toskin 2017-01-30 22:37:44 UTC
Congratulations on joining the main the Fedora repositories! There seems to be one or a couple remaining hiccups, though.

I had the previous version of your package, vbam-gtk, from RPM Fusion. Today, when installing system updates, I noticed that visualboyadvance-m from the Fedora Updates repo was obsoleting vbam, so I thought I'd try it out today to make sure everything still works. When I loaded a ROM, VisualBoyAdvance-M complained about not being able to find OpenAL, and generated this error log:

02:23:42 PM: libopenal.so: cannot open shared object file: No such file or directory
02:23:42 PM: OpenAL library could not be found on your system.  Please install the runtime from http://openal.org
02:23:42 PM: libopenal.so: cannot open shared object file: No such file or directory
02:23:42 PM: OpenAL library could not be found on your system.  Please install the runtime from http://openal.org


I'm using VisualBoyAdvance-M 2.0.0-0.7.Beta3 on Fedora 25 Workstation (64-bit).

The package openal-soft was already installed on my machine. Installing openal-soft-devel seems to have solved the problem. So I guess either VBA-M needs to be recompiled so that the binary doesn't need the OpenAL header files(?), or the OpenAL development package needs to be added to VBA-M's list of dependencies.

Comment 1 Jeremy Newton 2017-01-31 01:33:48 UTC
Hmm looks like there's a bug openal detection in vba-m. I'll make a patch and send it upstream ASAP.

In the meantime, you can work around the issue by either:

- Using sdl instead by selecting Options>Audio>Options>Configure then click on the "Advanced" tab and change the Device from openal to SDL.

- OR if you really want to use openal, install openal-soft-devel temporarily to silence this error. Once I push the update to fix this, remove the devel package to confirm the error still doesn't come up.


Thanks!

Comment 2 Jeremy Newton 2017-01-31 02:13:16 UTC
I've made a bug report upstream:
https://github.com/visualboyadvance-m/visualboyadvance-m/issues/69

And my workaround for the issue is currently building. I'll submit it to testing as soon as it's done.

Thanks again for submitting a bug report!

Comment 3 Fedora Update System 2017-01-31 03:41:48 UTC
visualboyadvance-m-2.0.0-0.9.Beta3.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2017-25f0a4fd75

Comment 4 Fedora Update System 2017-01-31 03:41:54 UTC
visualboyadvance-m-2.0.0-0.9.Beta3.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-ce80842eed

Comment 5 Fedora Update System 2017-01-31 22:50:54 UTC
visualboyadvance-m-2.0.0-0.9.Beta3.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-25f0a4fd75

Comment 6 Fedora Update System 2017-01-31 23:49:33 UTC
visualboyadvance-m-2.0.0-0.9.Beta3.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-ce80842eed

Comment 7 Fedora Update System 2017-02-09 04:21:58 UTC
visualboyadvance-m-2.0.0-0.9.Beta3.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2017-02-09 20:50:14 UTC
visualboyadvance-m-2.0.0-0.9.Beta3.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.