Bug 141777 - Hal does not detect LaCie usb hard drive
Hal does not detect LaCie usb hard drive
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
4
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: John (J5) Palmieri
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-03 13:35 EST by Sergio Pascual
Modified: 2013-03-13 00:47 EDT (History)
2 users (show)

See Also:
Fixed In Version: 0.5.7-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-03 05:21:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of dmesg (683 bytes, text/plain)
2004-12-03 13:40 EST, Sergio Pascual
no flags Details
Output of hald (153.88 KB, text/plain)
2004-12-09 07:04 EST, Sergio Pascual
no flags Details
Output of dmesg (18.81 KB, text/plain)
2005-07-01 05:24 EDT, Sergio Pascual
no flags Details
Output of hald (49.72 KB, text/plain)
2005-07-01 05:25 EDT, Sergio Pascual
no flags Details

  None (edit)
Description Sergio Pascual 2004-12-03 13:35:52 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20041020 Galeon/1.3.18

Description of problem:
I plug in the LaCie usb hard drive and it is detected by the usual usb
mechanism. The ouput of dmesg is attached below. 
When I click the Computer icon, the disk does not appear, as other usb
devices do. This disk used to work for me in FC2 with the old 
updfstab mechanism.



Version-Release number of selected component (if applicable):
hal-0.4.2-1.FC3

How reproducible:
Always

Steps to Reproduce:
1. Plugin the LaCie external usb disk
2. 
3.
    

Actual Results:  Nothing happens in the desktop

Expected Results:  The device appears in the Computer icon on the
gnome desktop.

Additional info:
Comment 1 Sergio Pascual 2004-12-03 13:40:07 EST
Created attachment 107858 [details]
Output of dmesg
Comment 2 David Zeuthen 2004-12-03 14:23:51 EST
Please attach the output of 'hald --daemon=no --verbose=yes' when
plugging in the disk.
Comment 3 Sergio Pascual 2004-12-09 07:04:23 EST
Created attachment 108195 [details]
Output of hald

I plugged the disk at 13:00 local time, so you can easily identify the
corresponding lines in the tail of the file.
Comment 4 David Zeuthen 2005-01-13 14:26:48 EST
Please see if this works with hal-0.4.5 available both in Rawhide and
FC3 updates. Thanks
Comment 5 Sergio Pascual 2005-01-14 13:58:13 EST
It is not working, sorry
Comment 6 Sergio Pascual 2005-01-18 14:21:17 EST
Additionally, the disk is not working at all with
kernel-2.6.10-1.741_FC3. I am back with  kernel-2.6.9-1.681_FC3
Comment 7 Bert DeKnuydt 2005-01-28 08:05:09 EST
Same problem here with 2.6.10-1.741_FC3 and hal-0.4.7-1.FC3.
Harddisk is LaCie Bigger disk.

Returning to 2.6.9-1.681_FC3 alone does not help. dmesg reports

>usb 1-2: control timeout on ep0in
>usb 1-2: device not accepting address 2, error -71
>usb 1-2: new high speed USB device using address 3
>usb 1-2: control timeout on ep0in
>usb 1-2: device not accepting address 3, error -71
Comment 8 Brett Peters 2005-02-17 20:14:21 EST
I have encounted this bug on several installations of FC3, with
several types of LaCie disks.  Unforutnately, the bug manifests
differently based on the FC3 up2date status and the type of LaCie
drive.  All LaCie drives were functional with FC1, RHEL3, and Windows XP.

1)  On a clean, up2date installation of FC3 with 2.6.10-1.766_FC3 and
hal-0.4.7-1.FC3, the computer will not recognize a 250GB LaCie Big
Drive with drives manufactured by WDC.  250GB LaCie Big Drives with
Maxtor drives will work, however.  The WDC drives will work if I boot
into the original FC3 kernel.

2)  A 500GB LaCie Big Drive does not work under either kernel
configuration of FC3, though it worked in FC1.

Comment 9 Bert DeKnuydt 2005-02-18 06:33:51 EST
We are now at 2.6.10-1.766_FC3 and I still get exactly the same problem.

My LaCie's are of the 1 TB variant, with Maxtor drives.  They worked
flawlessly on FC2 (no idea abt. FC1) and on the first few FC3 kernels. 

When I forcefully downgrade to 2.6.9-1.681_FC3 now though, it still
does not work. So I think hal is somehow the culprit ...
Comment 10 David Zeuthen 2005-03-21 12:50:28 EST
This seems to be a kernel bug, not a hal bug. If you want this fixed, file a bug
against the kernel (but do try against the latest kernel in Rawhide).
Comment 11 Sergio Pascual 2005-03-29 04:47:53 EST
With the kernels 2.6.9 of FC3, my disk was detected, a device appeared in /dev
and I could mount it by hand. That's why I send a bug against hal, no kernel
problem at those times.

It is with the kernels 2.6.10 where the kernel problem appears with my disk. I
can wait and see if the <a
href="https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=128602">bug
128602</a> (USB device dies with "control timeout on ep0in") gets solved and
after that check if the hal behavior is OK.
Comment 12 Sergio Pascual 2005-07-01 05:20:54 EDT
Here we are again, now in fedora core 4. After plugged in, the disk is recogniced
and a device appear in /dev for it. I can mount it by hand.

When I click the Computer icon, the disk does not appear, as other usb
devices do. This disk used to work for me in FC2 with the old 
updfstab mechanism.

Below I attach the output of dmesg and hald --daemon=no --verbose=yes
Comment 13 Sergio Pascual 2005-07-01 05:24:38 EDT
Created attachment 116228 [details]
Output of dmesg
Comment 14 Sergio Pascual 2005-07-01 05:25:25 EDT
Created attachment 116229 [details]
Output of hald
Comment 15 Sergio Pascual 2006-05-03 05:21:48 EDT
This particular problem is fixed in fc5, with hal-0.5.7-3 and
kernel-2.6.16-1.2096_FC5

Note You need to log in before you can comment on or make changes to this bug.