Bug 1417806 - goa-daemon logs "secret_password_lookup_sync() returned NULL" repeatedly
Summary: goa-daemon logs "secret_password_lookup_sync() returned NULL" repeatedly
Keywords:
Status: CLOSED DUPLICATE of bug 1340203
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-online-accounts
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Debarshi Ray
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-31 06:11 UTC by Zbigniew Jędrzejewski-Szmek
Modified: 2017-01-31 09:53 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-31 09:53:16 UTC


Attachments (Terms of Use)

Description Zbigniew Jędrzejewski-Szmek 2017-01-31 06:11:44 UTC
With a fairly standard new F25 installation:
$ journalctl -b|grep 'secret_password_lookup_sync() returned NULL'|wc -l
1037

Jan 31 01:03:41 goa-daemon[1870]: secret_password_lookup_sync() returned NULL
Jan 31 01:03:51 goa-daemon[1870]: secret_password_lookup_sync() returned NULL
Jan 31 01:04:25 goa-daemon[1870]: secret_password_lookup_sync() returned NULL
Jan 31 01:04:37 goa-daemon[1870]: secret_password_lookup_sync() returned NULL
Jan 31 01:05:01 goa-daemon[1870]: secret_password_lookup_sync() returned NULL
Jan 31 01:05:29 goa-daemon[1870]: secret_password_lookup_sync() returned NULL
Jan 31 01:05:45 goa-daemon[1870]: secret_password_lookup_sync() returned NULL
Jan 31 01:05:57 goa-daemon[1870]: secret_password_lookup_sync() returned NULL
Jan 31 01:06:15 goa-daemon[1870]: secret_password_lookup_sync() returned NULL
Jan 31 01:06:34 goa-daemon[1870]: secret_password_lookup_sync() returned NULL
Jan 31 01:06:58 goa-daemon[1870]: secret_password_lookup_sync() returned NULL

Those message are completely impenetrable and non-actionable for users.

Example entry:
_TRANSPORT=journal
_UID=1000
_GID=1000
_CAP_EFFECTIVE=0
_AUDIT_SESSION=3
_AUDIT_LOGINUID=1000
_SYSTEMD_OWNER_UID=1000
_SYSTEMD_UNIT=user@1000.service
_SYSTEMD_SLICE=user-1000.slice
_SYSTEMD_USER_SLICE=-.slice
_SELINUX_CONTEXT=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023
_SYSTEMD_CGROUP=/user.slice/user-1000.slice/user@1000.service/dbus.service
_SYSTEMD_USER_UNIT=dbus.service
PRIORITY=4
GLIB_OLD_LOG_API=1
_COMM=goa-daemon
_EXE=/usr/libexec/goa-daemon
_CMDLINE=/usr/libexec/goa-daemon
_PID=1870
MESSAGE=secret_password_lookup_sync() returned NULL
GLIB_DOMAIN=GoaBackend

Comment 1 Debarshi Ray 2017-01-31 09:50:36 UTC
(In reply to Zbigniew Jędrzejewski-Szmek from comment #0)
> With a fairly standard new F25 installation:
> $ journalctl -b|grep 'secret_password_lookup_sync() returned NULL'|wc -l
> 1037
> 
> Jan 31 01:03:41 goa-daemon[1870]: secret_password_lookup_sync() returned NULL
> Jan 31 01:03:51 goa-daemon[1870]: secret_password_lookup_sync() returned NULL
> Jan 31 01:04:25 goa-daemon[1870]: secret_password_lookup_sync() returned NULL
> Jan 31 01:04:37 goa-daemon[1870]: secret_password_lookup_sync() returned NULL
> Jan 31 01:05:01 goa-daemon[1870]: secret_password_lookup_sync() returned NULL
> Jan 31 01:05:29 goa-daemon[1870]: secret_password_lookup_sync() returned NULL
> Jan 31 01:05:45 goa-daemon[1870]: secret_password_lookup_sync() returned NULL
> Jan 31 01:05:57 goa-daemon[1870]: secret_password_lookup_sync() returned NULL
> Jan 31 01:06:15 goa-daemon[1870]: secret_password_lookup_sync() returned NULL
> Jan 31 01:06:34 goa-daemon[1870]: secret_password_lookup_sync() returned NULL
> Jan 31 01:06:58 goa-daemon[1870]: secret_password_lookup_sync() returned NULL
> 
> Those message are completely impenetrable and non-actionable for users.

Because systemd --user broke the GNOME user session.

Comment 2 Debarshi Ray 2017-01-31 09:53:16 UTC

*** This bug has been marked as a duplicate of bug 1340203 ***


Note You need to log in before you can comment on or make changes to this bug.