Bug 1417816 - Remote data sync setup should show up the scheduled time with 2 digit precision for hours and minutes
Summary: Remote data sync setup should show up the scheduled time with 2 digit precisi...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Gluster
Version: 4.1.0
Hardware: x86_64
OS: Linux
medium
medium vote
Target Milestone: ovirt-4.1.1
: 4.1.1.3
Assignee: Sahina Bose
QA Contact: SATHEESARAN
URL:
Whiteboard:
Depends On:
Blocks: Gluster-HC-2
TreeView+ depends on / blocked
 
Reported: 2017-01-31 07:29 UTC by SATHEESARAN
Modified: 2017-04-21 09:31 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-04-21 09:31:56 UTC
oVirt Team: Gluster
rule-engine: ovirt-4.1+
rule-engine: planning_ack+
rule-engine: devel_ack+
sasundar: testing_ack+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 72291 master MERGED engine: format DR schedule representation 2017-02-21 07:12:05 UTC
oVirt gerrit 72734 ovirt-engine-4.1 MERGED engine: format DR schedule representation 2017-02-21 09:59:44 UTC

Description SATHEESARAN 2017-01-31 07:29:18 UTC
Description of problem:
-----------------------
When the schedule for the remote data sync for glusterfs data domain is set, the scheduled time is displayed in UI as %d:%d. UI scheduled time should be displayed with leading zeroes in case of single digit for hours & minutes, to make it appeal as time with hours and minutes

Version-Release number of selected component (if applicable):
-------------------------------------------------------------
oVirt Engine Version: 4.1.0.3-0.0

How reproducible:
-----------------
Always

Steps to Reproduce:
-------------------
1. Create a data domain backed with gluster replica 3 volume which is managed in the same cluster
2. Create a remote data sync for that data domain 
3. Look for the scheduled time in case of hours and minutes with single digit

Actual results:
---------------
When hours and minutes are with single digit, there are no leading zeroes to make the schedule looks like time representation
For example: 5:9, 6:2

Expected results:
-----------------
When hours and minutes are with single digit, there should be leading zeroes to make the schedule look like time representation
For example: 05:09, 06:02

Comment 1 SATHEESARAN 2017-03-29 11:06:12 UTC
Tested with RHV 4.1.1-5 and the schedule is displayed with 2 digit precision


Note You need to log in before you can comment on or make changes to this bug.