Bug 1417824 - [RFE] Multitenancy Support for puppet classes
Summary: [RFE] Multitenancy Support for puppet classes
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Organizations and Locations
Version: Unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-31 07:53 UTC by orabin
Modified: 2019-08-12 14:08 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-10-05 17:25:50 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description orabin 2017-01-31 07:53:53 UTC
Description of problem:
Puppet classes are not connected to organizations so a user from organization A can see and edit smart class parameters and smart variables created by a user from organization B.

Steps to Reproduce:
1. Create user A with permissions to organization A only
2. Create user B with permissions to organization B only
3. Log in as user A, go to Configure -> Classes and edit a puppet class
4. Add a smart variable
5. Log in as user B, go to Configure -> Classes and edit the same puppet class
6. Go to Smart Variables tab

Actual results:
The smart variable added by user A is visible and can be edited


Expected results:
The smart variable added by user A is hidden because the user is not in organization A


Additional info:

Comment 4 Bryan Kearney 2017-10-05 17:25:50 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and we do not expect this to be implemented in product in the forseeable future. We are therefore closing this out as WONTFIX. If you have any concerns about this, please feel free to contact Rich Jerrido or Bryan Kearney. Thank you.


Note You need to log in before you can comment on or make changes to this bug.