Bug 141789 - Spontaneous reboots with FC3 SMP kernel but not stock 2.6.9
Spontaneous reboots with FC3 SMP kernel but not stock 2.6.9
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Depends On:
  Show dependency treegraph
Reported: 2004-12-03 14:59 EST by Martin Smith
Modified: 2015-01-04 17:13 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-12-04 14:29:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Output from lspci (883 bytes, text/plain)
2004-12-03 15:01 EST, Martin Smith
no flags Details

  None (edit)
Description Martin Smith 2004-12-03 14:59:27 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3)

Description of problem:
With the current FC3 kernel my dual PIII machine reboots overnight
every night, while cron jobs are running, and at occasional other
times seemingly randomly. There are no messages logged by syslog when
this happens. E.g this morning the log was:

Dec  3 04:01:01 pandora crond(pam_unix)[4301]: session closed for user
Dec  3 04:04:28 pandora syslogd 1.4.1: restart.
Dec  3 04:04:28 pandora syslog: syslogd startup succeeded
Dec  3 04:04:28 pandora kernel: klogd 1.4.1, log source = /proc/kmsg
Dec  3 04:04:28 pandora kernel: Linux version 2.6.9-1.681_FC3smp
(bhcompile@tweety.build.redhat.com) (gcc version 3.4.2 20041017 (Red
Hat 3.4.2-6.fc3)) #1 SMP Thu Nov 18 15:19:10 EST 2004

I can normally provoke this reboot by running one of the scripts,
either the cron.daily slocate or an rsync script to update my portage
mirror usually does it. 

Initially I thought it was a hardware problem but disk and memory
diagnostics all passed. 

I have reverted to a plain 2.6.9 SMP kernel and so far have not seen
the failure happen. I've tried running the scripts that crash FC3
several times and they worked. This kernel was based on the redhat
config for i686 smp but with reiserfs + ext3 compiled in and for PIII
rather than P-PRO.

I don't really have a lot of other information that I can provide at
the moment. The machine is a mail server among other things and I
can't really leave it down for extended intervals for experiments.

I have a feeling this has been happening for a while, possibly with
FC2 as well. The machine has no console and runs unattended and a
couple of minutes downtime each day might have gone unnoticed.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Boot machine 
2. Wait all night or run one of the intensive daily cron jobs

Actual Results:  Reboot every day early in the morning or at random

Expected Results:  No kaboom!

Additional info:

The machine has two IDE disks, a SCSI DDS tape drive and DVD-RAM.
Otherwise its a pretty basic configuration.
Comment 1 Martin Smith 2004-12-03 15:01:40 EST
Created attachment 107862 [details]
Output from lspci
Comment 2 Martin Smith 2004-12-04 04:28:26 EST
I've now managed to reproduce this reboot with standard 2.6.9 by
repeatedly running the slocate cron script. 

I guess this increases the chance that it is a hardware problem.
Comment 3 Dave Jones 2004-12-04 14:29:50 EST
or a problem thats in the upstream kernel. Try the 2.6.10rc patches,
and if its still repeatable, you might want to let
linux-kernel@vger.kernel.org know about it.

Either way, it doesn't sound like something we've introduced, so
punting this to 'upstream'.  If upstream finds a single fix for your
problem, feel free to reopen, and attach a pointer to it.

(Though Fedora may have moved on past 2.6.9 at that point)

Note You need to log in before you can comment on or make changes to this bug.