Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1417902 - Missing pre-compiled python files in /usr/lib/python3.5/site-packages/dnf-plugins/
Summary: Missing pre-compiled python files in /usr/lib/python3.5/site-packages/dnf-plu...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf-plugins-core
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: rpm-software-management
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-31 11:45 UTC by Christian Stadelmann
Modified: 2017-06-14 13:03 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-06-14 13:03:09 UTC
Type: Bug


Attachments (Terms of Use)

Description Christian Stadelmann 2017-01-31 11:45:09 UTC
Version-Release number of selected component (if applicable):
0.1.21-4.fc25

How reproducible:
always – packaging issue.

Steps to Reproduce:
1. install dnf-plugins-core for python3
2. have a look at the files installed

Actual results:
All of these python source files don't ship pre-compiled in the RPM package:
/usr/lib/python3.5/site-packages/dnf-plugins/builddep.py
/usr/lib/python3.5/site-packages/dnf-plugins/config_manager.py
/usr/lib/python3.5/site-packages/dnf-plugins/copr.py
/usr/lib/python3.5/site-packages/dnf-plugins/debuginfo-install.py
/usr/lib/python3.5/site-packages/dnf-plugins/download.py
/usr/lib/python3.5/site-packages/dnf-plugins/generate_completion_cache.py
/usr/lib/python3.5/site-packages/dnf-plugins/needs_restarting.py
/usr/lib/python3.5/site-packages/dnf-plugins/noroot.py
/usr/lib/python3.5/site-packages/dnf-plugins/protected_packages.py
/usr/lib/python3.5/site-packages/dnf-plugins/repoquery.py
/usr/lib/python3.5/site-packages/dnf-plugins/reposync.py

Expected results:
either all files should be precompiled, or none. Since all the other dnf python3 packages are shipping pre-compiled files, dnf-plugins-core should too.

Comment 1 Igor Gnatenko 2017-01-31 12:11:43 UTC
commit 7dd66e54f47ff00cce8bdc0a3b5021027afab1b5
Author: Igor Gnatenko <i.gnatenko.brain@gmail.com>
Date:   Thu Dec 1 19:58:59 2016 +0100

    spec: include __pycache__ files
    
    Reported-by: Miro Hrončok <miro@redhat.com>
    Signed-off-by: Igor Gnatenko <i.gnatenko.brain@gmail.com>
    
    Closes: #196
    Approved by: ignatenkobrain

Comment 2 Jaroslav Mracek 2017-06-14 13:03:09 UTC
Patch released in dnf-plugins-core-1.0.2-1


Note You need to log in before you can comment on or make changes to this bug.