Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1417904 - [fr_FR, es_ES] [Admin Portal] Text overlap and UI distortion observed on data center->QoS->storage->new page.
Summary: [fr_FR, es_ES] [Admin Portal] Text overlap and UI distortion observed on data...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin
Version: 4.1.0.3
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: ovirt-4.1.7
: 4.1.7.4
Assignee: Phillip Bailey
QA Contact: Bhushan Barve
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-31 11:48 UTC by Bhushan Barve
Modified: 2017-11-13 12:26 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-13 12:26:04 UTC
oVirt Team: SLA
rule-engine: ovirt-4.1+
rule-engine: ovirt-4.2+
mgoldboi: planning_ack+
rule-engine: devel_ack+
bbarve: testing_ack+


Attachments (Terms of Use)
ja_JP_UI_distortion (84.79 KB, image/png)
2017-01-31 11:48 UTC, Bhushan Barve
no flags Details
fr_FR_text_overlap (85.15 KB, image/png)
2017-01-31 11:50 UTC, Bhushan Barve
no flags Details
Screenshot of the storage dialog window with the UI issue present. (18.16 KB, image/png)
2017-04-05 18:57 UTC, Phillip Bailey
no flags Details
Screenshot of the storage dialog window with the patch applied. (20.14 KB, image/png)
2017-04-05 18:59 UTC, Phillip Bailey
no flags Details
distortion on fr_FR_reopened (73.64 KB, image/png)
2017-05-17 10:15 UTC, Bhushan Barve
no flags Details


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 75242 0 ovirt-engine-4.1 MERGED webadmin: Update QoS popup layout 2017-04-19 09:31:43 UTC
oVirt gerrit 81280 0 ovirt-engine-4.1 MERGED webadmin: Expand width of new QoS popup 2017-10-15 14:38:31 UTC
oVirt gerrit 82832 0 ovirt-engine-4.1 MERGED webadmin: Further expand width of QoS popup for Firefox 2017-10-16 15:37:38 UTC

Description Bhushan Barve 2017-01-31 11:48:44 UTC
Created attachment 1246195 [details]
ja_JP_UI_distortion

Description of problem: For all languages, there is text overlapping and UI distortion observed on data center->QoS->storage->new page screen. The UI distortion is seen more evidently on ja_JP locale, while on other locales there's minor text overlap. Please refer attached screenshots.


Version-Release number of selected component (if applicable):


How reproducible:
 Red Hat Virtualization Manager Version: 4.1.0.3-0.1.el7 

Steps to Reproduce:
1. login to admin portal
2. go to data center->QoS->storage->new page screen
3. observe the UI.

Actual results:
The UI distortion and text overlap can be seen. 

Expected results:
The UI should be without distortion and overlap.

Additional info:

Comment 1 Bhushan Barve 2017-01-31 11:50:15 UTC
Created attachment 1246196 [details]
fr_FR_text_overlap

Comment 2 Oved Ourfali 2017-02-15 13:15:56 UTC
Moving to the relevant team.
If you need assistance let us know.

Comment 3 Doron Fediuck 2017-04-05 10:27:51 UTC
Phillip,
can you please try to reproduce based on the attachments and come up with patches? We'll ask someone with FR or JP locale to verify it.

Comment 4 Phillip Bailey 2017-04-05 12:16:57 UTC
(In reply to Doron Fediuck from comment #3)
> Phillip,
> can you please try to reproduce based on the attachments and come up with
> patches? We'll ask someone with FR or JP locale to verify it.

Absolutely. I'm on it.

Comment 5 Phillip Bailey 2017-04-05 18:57:55 UTC
Created attachment 1269059 [details]
Screenshot of the storage dialog window with the UI issue present.

Comment 6 Phillip Bailey 2017-04-05 18:59:55 UTC
Created attachment 1269066 [details]
Screenshot of the storage dialog window with the patch applied.

Comment 7 Phillip Bailey 2017-04-05 19:03:11 UTC
(In reply to Doron Fediuck from comment #3)
> Phillip,
> can you please try to reproduce based on the attachments and come up with
> patches? We'll ask someone with FR or JP locale to verify it.

Could you please have someone test the submitted patch? I have attached screenshots showing that the same issue was present when using the EN locale and that the patch corrected the problem there.

Comment 8 Yuko Katabami 2017-05-15 11:34:56 UTC
Is a test environment available for me to use?
I only have 4.1.1.8-0.1.el7.

Comment 9 Bhushan Barve 2017-05-17 10:14:42 UTC
Checked with 4.1.2.2-0.1.el7

The issue is no more observed for ja_JP, zh_CN and ko_Kr locales.
However it is still reproducible with fr_FR and es_ES locales. The UI looks distorted with buttons and other component's position affected. Please refer attached screenshot for fr_FR. 

Changing it back to assigned and changing the locale tags in the summary accordingly.

Comment 10 Red Hat Bugzilla Rules Engine 2017-05-17 10:14:53 UTC
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.

Comment 11 Bhushan Barve 2017-05-17 10:15:55 UTC
Created attachment 1279614 [details]
distortion on fr_FR_reopened

Comment 14 Yuko Katabami 2017-10-26 09:15:41 UTC
Hi Bhushan, 

Could you please QA this BZ?

Comment 16 Bhushan Barve 2017-10-27 08:08:03 UTC
Checked with  Red Hat Virtualization Manager 버전: 4.1.7.4-0.1.el7 

The UI looks fine now for fr and es locales.

Closing it.


Note You need to log in before you can comment on or make changes to this bug.