Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1417937 - Details link and paging on content tab throws HTTP Status 404
Summary: Details link and paging on content tab throws HTTP Status 404
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: JBoss Operations Network
Classification: JBoss
Component: UI
Version: JON 3.3.7,JON 3.3.8
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: CR01
: JON 3.3.9
Assignee: Josejulio Martínez
QA Contact: Prachi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-31 13:04 UTC by Filip Brychta
Modified: 2017-10-02 17:21 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-10-02 17:21:51 UTC
Type: Bug


Attachments (Terms of Use)
content tab (181.19 KB, image/png)
2017-01-31 13:04 UTC, Filip Brychta
no flags Details
content tab error (92.86 KB, image/png)
2017-01-31 13:05 UTC, Filip Brychta
no flags Details
qa-failed-blank-column (153.55 KB, image/png)
2017-09-06 06:39 UTC, Jeeva Kandasamy
no flags Details
verified (148.62 KB, image/png)
2017-09-20 18:14 UTC, Jeeva Kandasamy
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:2846 0 normal SHIPPED_LIVE Red Hat JBoss Operations Network 3.3.9 bug fix update 2017-10-02 21:21:28 UTC

Description Filip Brychta 2017-01-31 13:04:54 UTC
Created attachment 1246226 [details]
content tab

Description of problem:
See attached contentTab.png and contentTabError.png
Error is visible when clicking on details link or paging.

Version-Release number of selected component (if applicable):
Tried with 3.3.7 and 3.3.8 but it will be probably in earlier versions as well.

How reproducible:
Always

Steps to Reproduce:
1. create EAP deployment
2. navigate to that deployment -> Content tab
3. click on any details link or paging element

Actual results:
See attached contentTabError.png

Expected results:
No errors

Additional info:

Comment 1 Filip Brychta 2017-01-31 13:05:13 UTC
Created attachment 1246227 [details]
content tab error

Comment 10 Josejulio Martínez 2017-08-23 15:48:01 UTC
commit 902aa26d90fe293bb69658d335893dddbc3239ce
Merge: 1304f1f 06ea6af
Author: Michael Burman <yak@iki.fi>
Date:   Wed Aug 23 16:48:31 2017 +0300

    Merge pull request #312 from josejulio/bugs/1417937
    
    Bug 1417937 - Details link and paging on content tab throws HTTP Stat…

commit 06ea6afb006fc44387ad7bdd51e4e1ba3176d49a
Author: Josejulio Martínez <jmartine@redhat.com>
Date:   Tue Aug 15 11:36:08 2017 -0500

    Remove "View" links

commit 59a1025ee1b0c8c830f31888816a2bc48687de0e
Author: Josejulio Martínez <jmartine@redhat.com>
Date:   Wed Aug 2 18:54:23 2017 -0500

    Bug 1417937 - Details link and paging on content tab throws HTTP Status 404
     Fixes pagination and "view" links.

Comment 12 Simeon Pinder 2017-09-01 15:34:18 UTC
Moving to ON_QA as available for test with the following binary:
http://download.eng.bos.redhat.com/brewroot/packages/org.jboss.on-jboss-on-parent/3.3.0.GA/133/maven/org/jboss/on/jon-server-patch/3.3.0.GA/jon-server-patch-3.3.0.GA.zip

*NOTE Build represents JON 3.3.9 DR01 build.

Please report issues as you encounter them.

Comment 13 Jeeva Kandasamy 2017-09-06 06:39:04 UTC
Created attachment 1322496 [details]
qa-failed-blank-column

fix removed links. However, I can see blank column on end of the table. see the attached screenshot.

Version info:
-------------

OS: Fedora 26
Browser: Firefox 55.0.2 (64-bit)

JBoss Operations Network	
Version: 3.3.0.GA Update 09
Build Number: 74b22f5:8c38c0a
GWT Version: 2.5.0
SmartGWT Version: 3.0p

Comment 14 Josejulio Martínez 2017-09-06 21:56:49 UTC
Firefox needed something else.

commit bed752f673a55ad386249694aac170ce757d631f
Merge: 211399f 674af7c
Author: Ruben Vargas <ruben.vp8510@gmail.com>
Date:   Wed Sep 6 16:53:34 2017 -0500

    Merge pull request #321 from josejulio/bugs/1417937
    
    Bug 1417937 - Updates columnsWidth to match the column count

commit 674af7cd5c1fa3c86889c16edd20bfe7cf419a81
Author: Josejulio Martínez <jmartine@redhat.com>
Date:   Wed Sep 6 11:43:00 2017 -0500

    Bug 1417937 - Updates columnsWidth to match the column count

Comment 16 Simeon Pinder 2017-09-19 11:33:19 UTC
Moving to ON_QA.

JON 3.3.9 CR01 artifacts are available for test from here:
http://download.eng.bos.redhat.com/brewroot/packages/org.jboss.on-jboss-on-parent/3.3.0.GA/135/maven/org/jboss/on/jon-server-patch/3.3.0.GA/jon-server-patch-3.3.0.GA.zip
 *Note: jon-server-patch-3.3.0.GA.zip maps to CR01 build of
 jon-server-3.3.0.GA-update-09.zip.

Comment 17 Jeeva Kandasamy 2017-09-20 18:14:53 UTC
Created attachment 1328528 [details]
verified

Works as expected. I do not see any blank column on the table.

Version info:
-------------

OS: Fedora 26
Browser: Firefox 55.0.3 (64-bit)

JBoss Operations Network	
Version: 3.3.0.GA Update 09
Build Number: 44ba698:204e925
GWT Version: 2.5.0
SmartGWT Version: 3.0p

Comment 18 errata-xmlrpc 2017-10-02 17:21:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:2846


Note You need to log in before you can comment on or make changes to this bug.