Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1417938 - Incorrect error message displayed when hot pluging cpu sockets from vsphere vm
Summary: Incorrect error message displayed when hot pluging cpu sockets from vsphere vm
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Appliance
Version: 5.7.0
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: GA
: cfme-future
Assignee: Adam Grare
QA Contact: luke couzens
URL:
Whiteboard: reconfigure:vmware
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-31 13:08 UTC by luke couzens
Modified: 2017-03-06 16:24 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-03-06 16:24:04 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)

Description luke couzens 2017-01-31 13:08:36 UTC
Description of problem:If you decrease cpu socket count from a vsphere vm while powered on you receive an inaccurate error message.

Version-Release number of selected component (if applicable):5.7.1.0


How reproducible:100%


Steps to Reproduce:
1.Add vsphere provider to CFME appliance
2.Provision new vm (rhel7 in my case)
3.Turn on cpu hot plug withing VMWare
4.Reconfigure the vm reducing its cpu socket count

Actual results: Error: CPU hot plug is not supported for this virtual machine.


Expected results:I believe the correct error should be something like: 'unable to decrease cpu count in powered on state'.


Additional info:
Test was ran with vsphere 5.5 provider

Comment 2 Adam Grare 2017-03-06 16:24:04 UTC
This was fixed by https://github.com/ManageIQ/manageiq/pull/12275 and is in 5.8
We validate the requested changes against the hot-plug settings on the VM and print a more informative error message, in this case it will read "Error: Cannot remove CPUs from a running VM"

It should be noted that the error message that you reported actually comes from VMware not CFME, the reason being that while cpu-hot-add is enabled cpu-hot-remove is not, they just have one error message to report that.

That PR depends on a SQL migration (https://github.com/ManageIQ/manageiq/pull/12145) hence why it was not backported.


Note You need to log in before you can comment on or make changes to this bug.