Bug 1417962 - incorrect IP address of kvm guest RHEL5 on overview page (hardware profile)
Summary: incorrect IP address of kvm guest RHEL5 on overview page (hardware profile)
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: rhn-client-tools
Version: 5.11
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Tomáš Kašpárek
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-31 14:07 UTC by Pavel Studeník
Modified: 2017-08-21 15:09 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-21 15:09:56 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Pavel Studeník 2017-01-31 14:07:03 UTC
Description of problem:
I created KVM virtual guest (RHEL5) by Satellite 5 (webui) and the new registered system (guest) has set incorrect IP address. I go to profile of the system and see following information:

IP Address: 	10.16.186.64

But networking of created system looks following:

eth0 	192.168.122.88 	255.255.255.0 	192.168.122.255 	00:16:3e:2d:13:aa 	8139cp
lo 	127.0.0.1 	255.0.0.0 	0.0.0.0 	00:00:00:00:00:00 	loopback

New created KVM system is named by its host - same hostname and IP address.

Problem is only on RHEL5 guest. The version of the host is not important.

It seems as regressions. Because It works good in the past.

Version-Release number of selected component (if applicable):
rhn-setup-0.4.20.1-9.el5
rhnsd-4.7.0-14.el5
yum-rhn-plugin-0.5.4.1-7.el5
rhn-client-tools-0.4.20.1-9.el5
rhn-check-0.4.20.1-9.el5

How reproducible:
only guest RHEL 5

Steps to Reproduce:
1. created kvm guest RHEL5 by webui
2. look at created profile on web
3. incorrect IP address on hardware profile

Actual results:
incorrect IP address on profile

Expected results:
correct IP address on system profile

Comment 2 Pavel Studeník 2017-02-01 11:02:45 UTC
Same problem I see on Fedoras with spacewalk nightly packages"

Comment 4 Jan Dobes 2017-08-21 15:09:56 UTC
This incorrect IP is only reported from RHEL 5 guest which has same hostname as it's host. After I changed hostname and executed rhn-profile-sync, IP was updated to correct one.

This is bug in RHEL 5 version of rhn-client-tools package, this bug doesn't seem to be reproducible using upstream version.

As this bug
* is reproducible only under circumstances not likely to be in production environment (same hostname for host and guest)
* is in RHEL 5 package (in ELS state, no next release is planned)
* doesn't have any customer cases attached

I'm inclined to close this bug.


Note You need to log in before you can comment on or make changes to this bug.