Bug 1417980 - Set up of Manila with NetApp driver fails in Overcloud unless ManilaNetAppTraceFlags value is supplied
Summary: Set up of Manila with NetApp driver fails in Overcloud unless ManilaNetAppTra...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: z3
: 10.0 (Newton)
Assignee: Jan Provaznik
QA Contact: Dustin Schoenbrun
Don Domingo
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-31 14:27 UTC by Amit
Modified: 2017-06-28 14:44 UTC (History)
8 users (show)

Fixed In Version: openstack-tripleo-heat-templates-5.2.0-18.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-06-28 14:44:12 UTC
Target Upstream Version:


Attachments (Terms of Use)
Manila (1.41 KB, text/plain)
2017-01-31 14:27 UTC, Amit
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Launchpad 1660930 0 None None None 2017-02-01 10:01:14 UTC
OpenStack gerrit 444314 0 None None None 2017-03-10 14:23:44 UTC
Red Hat Product Errata RHBA-2017:1585 0 normal SHIPPED_LIVE Red Hat OpenStack Platform 10 director Bug Fix Advisory 2017-06-28 18:42:51 UTC

Description Amit 2017-01-31 14:27:34 UTC
Created attachment 1246266 [details]
Manila

Description of problem:
I am trying to set up Manila with NetApp driver in Overcloud using Heat environment files. I set up the environment files and included them with a "-e" parameter in Overcloud creation.

The deployment fails at:
AllNodesDeploySteps    | OS::TripleO::PostDeploySteps     

If i check the os-collect-config logs I see this:

Jan 31 03:55:02 overcloud-controller-0.localdomain os-collect-config[6843]: Error: Could not find data item manila::backend::netapp::netapp_trace_flags in any Hiera data file and no default supplied at /etc/puppet/modules/tripleo/manifests/profile/pacemaker/manila.pp:117 on node overcloud-controller-0.localdomain
Jan 31 03:55:02 overcloud-controller-0.localdomain os-collect-config[6843]: Error: Could not find data item manila::backend::netapp::netapp_trace_flags in any Hiera data file and no default supplied at /etc/puppet/modules/tripleo/manifests/profile/pacemaker/manila.pp: 117 on node overcloud-controller-0.localdomain
Jan 31 03:55:02 overcloud-controller-0.localdomain os-collect-config[6843]: [2017-01-31 03:55:02,102] (heat-config) [ERROR] Error running /var/lib/heat-config/heat-config-puppet/bce686a8-acdf-4ba9-b903-0b



Version-Release number of selected component (if applicable):
OSP 10

How reproducible:
Attaching the used  manila-netapp-config.yaml  file.

Steps to Reproduce:
1.Include the env file manila-netapp-config.yaml in the overcloud deploy command with an "-e" option
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Dustin Schoenbrun 2017-01-31 14:44:30 UTC
Taking a quick look at this shows that the netapp_trace_flags parameter is present but is empty. I wonder if it is a parameter that, if present, needs to have a value or if you do not need tracing that you can just remove that parameter. Will have to investigate.

Comment 3 Ben Swartzlander 2017-01-31 14:55:55 UTC
The netapp_trace_flags option can be set to the empty string. That's no problem.

Comment 4 Dan Macpherson 2017-02-01 06:16:52 UTC
ddomingo pointed me to this bug.

As a workaround, you might want to set ManilaNetappTraceFlags to either ' ' or "''" rather than ''. I think Heat interprets '' as a null value and ignores the param when populating the hiera data.

So depending on what you want netapp_trace_flags to conatin, try one of the following:
ManilaNetappTraceFlags: ' '   # sets to blank space
ManilaNetappTraceFlags: "''"  # sets to single quotes

Comment 5 Red Hat Bugzilla Rules Engine 2017-02-01 10:04:50 UTC
This bugzilla has been removed from the release and needs to be reviewed for targeting another release.

Comment 6 Jan Provaznik 2017-02-01 10:37:19 UTC
related issue: https://bugzilla.redhat.com/show_bug.cgi?id=1313220

Comment 7 Tom Barron 2017-02-01 19:01:45 UTC
Although we've posted a review that sets ManilaNetAppTraceFlags to ' ' instead of to '', (1) the latter setting should theoretically work, and (2) we're not able to replicate the issue using upstream tripleo master code.  Perhaps the related issue cited in https://bugzilla.redhat.com/show_bug.cgi?id=1417980#c6 has been resolved.

Since the customer has reported in IRC that the workaround of setting the trace flags to 'method' in his version of the manila netapp environment file works and is acceptable we're going to see if we can reproduce the issue with RHOS10 OSPd and if so get a better understanding of the difference with master before pushing ahead with the current posted review.

Comment 8 Dustin Schoenbrun 2017-02-10 20:52:15 UTC
I tried this out on the latest available OSP-10 build and I was able to get the install to fail with the netapp_trace_flags value not present. So I can verify that this is indeed present in the current build of OSP-10.

Comment 10 Jan Provaznik 2017-03-10 14:20:54 UTC
upstream patch for newton:
https://review.openstack.org/#/c/444314/

A fix for later releases is not needed because in Ocata Tripleo switched to JSON format of hieradata - https://review.openstack.org/#/c/384757/

Comment 14 Dustin Schoenbrun 2017-05-26 19:40:52 UTC
Using the 2017-05-23.4 OSP-10 puddle with the openstack-tripleo-heat-templates-5.2.0-18.el7ost.noarch package I was able to set up the OpenStack instance without specifying the ManilaNetAppTraceFlags option in the parameters to the Heat template that configures the NetApp cDOT Manila driver. The OSP instance was setup correctly. After this, I logged into each controller node in the environment and looked at the Manila configuration files to ensure that if the option was specified in the configuration file that it did not have a value. Every node had the option present in the NetApp configuration stanza, but none had values, thus meaning that no tracing was enabled. Marking the bug as VERIFIED.

Comment 16 errata-xmlrpc 2017-06-28 14:44:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1585


Note You need to log in before you can comment on or make changes to this bug.