Bug 1418002 - [BUG] RHV cisco_ucs power management restart displays misleading message.
Summary: [BUG] RHV cisco_ucs power management restart displays misleading message.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 4.0.6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ovirt-4.1.1
: ---
Assignee: Ravi Nori
QA Contact: Petr Matyáš
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-31 14:59 UTC by Ulhas Surse
Modified: 2020-03-11 15:47 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-04-25 00:43:48 UTC
oVirt Team: Infra
Target Upstream Version:


Attachments (Terms of Use)
power management (164.68 KB, image/jpeg)
2017-01-31 15:02 UTC, Ulhas Surse
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:0997 0 normal SHIPPED_LIVE Red Hat Virtualization Manager (ovirt-engine) 4.1 GA 2017-04-18 20:11:26 UTC
oVirt gerrit 71906 0 None None None 2017-02-13 14:37:22 UTC
oVirt gerrit 72096 0 None None None 2017-02-13 14:38:38 UTC

Description Ulhas Surse 2017-01-31 14:59:56 UTC
Description of problem:


Version-Release number of selected component (if applicable):
Red Hat Virtualization Manager Version: 4.0.6.3-0.1.el7ev

How reproducible:
Always

Steps to Reproduce:
1. Create Cluster with power management enabled. (CISCO_UCS)
2. Put the host on maintenance so that the vms running on this will migrate to other host. 
3. Now After going into "MAINTENANCE" status, try to reboot host by going to Power Management > Restart

Error screen appears: 

   Are you sure you want to Restart the following Host(s), ungracefully stopping running VM(s)?
    
     - <Hostname>

Actual results:

  Error messages displayed even the host does not have any VMs running on it. 

   # vdsClient -s 0 list table  --> Shows nothing

   # ps aux | grep qemu  --> shows nothing

Expected results:

  Messages should not be there. 

Additional info:

Comment 1 Ulhas Surse 2017-01-31 15:02:03 UTC
Created attachment 1246335 [details]
power management

Comment 2 Martin Perina 2017-02-01 13:25:06 UTC
Power Management Restart of the host can be executed even when host is Up (not only in Maintenance), so that's why we show this warning. This warning is shown in webadmin so if we checked for a host status and we didn't display warning if host was in Maintenance, it may not be enough, because host status could change in the mean time.

So from my point of view executing PM restart is a bit dangerous operation, so I'd prefer to not change current behaviour (display warning always) instead if  adding a check for host status which may not be reliable.

Moran?

Comment 3 Martin Perina 2017-02-08 11:50:29 UTC
We have discussed offline, Ravi could you please change the message in dialog to:

  Are you sure you want to Restart the following Host(s)? If there are any VM(s) running on the host, they will be ungracefully stopped.

Comment 5 Petr Matyáš 2017-02-20 14:53:37 UTC
Verified on 4.1.1-2


Note You need to log in before you can comment on or make changes to this bug.