Bug 1418027 - group rtlsdr should be a system group, not a user group
Summary: group rtlsdr should be a system group, not a user group
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: rtl-sdr
Version: 25
Hardware: Unspecified
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Jaroslav Škarvada
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-31 16:20 UTC by Edgar Hoch
Modified: 2017-02-09 20:24 UTC (History)
1 user (show)

Fixed In Version: rtl-sdr-0.5.3-7.fc25
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-09 20:24:24 UTC
Type: Bug


Attachments (Terms of Use)
patch for rtl-sdr.spec to create a system group instead of a user group (312 bytes, patch)
2017-01-31 16:22 UTC, Edgar Hoch
no flags Details | Diff

Description Edgar Hoch 2017-01-31 16:20:50 UTC
Description of problem:
Package rtl-sdr creates a group rtlsdr with GID in user range instead of system range:

# grep rtlsdr /etc/group
rtlsdr:x:1000:

But packages should create groups in the system GID range, because GIDs from 1000 are reserved for users. Add option "--system" to groupadd command in preinstall script would solve the problem (for new installations).


Version-Release number of selected component (if applicable):
rtl-sdr-0.5.3-6.fc25.x86_64

How reproducible:
Always

Steps to Reproduce:
1. dnf install rtl-sdr
2. grep rtlsdr /etc/group

Actual results:
GID is 1000 or higher.

Expected results:
GID is less than 1000 (e.g. in the range from SYS_GID_MIN to SYS_GID_MAX)

Comment 1 Edgar Hoch 2017-01-31 16:22:13 UTC
Created attachment 1246360 [details]
patch for rtl-sdr.spec to create a system group instead of a user group

Comment 2 Jaroslav Škarvada 2017-02-01 14:47:25 UTC
Thanks.

Comment 3 Fedora Update System 2017-02-01 16:18:12 UTC
rtl-sdr-0.5.3-7.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-34fd78ff2f

Comment 4 Fedora Update System 2017-02-01 23:52:31 UTC
rtl-sdr-0.5.3-7.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-34fd78ff2f

Comment 5 Fedora Update System 2017-02-09 20:24:24 UTC
rtl-sdr-0.5.3-7.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.