Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1418048 - Request to include LIS 4.1.3 or the module equivalent in RHEL 6.10
Summary: Request to include LIS 4.1.3 or the module equivalent in RHEL 6.10
Keywords:
Status: CLOSED DUPLICATE of bug 1333167
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel
Version: 6.8
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: Virtualization Maintenance
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-31 17:18 UTC by John Pittman
Modified: 2020-06-11 13:15 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-31 17:57:22 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description John Pittman 2017-01-31 17:18:29 UTC
Description of problem:

Virtual guests on Microsoft hypervisor failing to dump vmcore intermittently with a "lost interrupt".

Issue can be seen below:
  - https://paste.fedoraproject.org/541688/raw

Requesting to include LIS 4.1.3 or the module equivalent in RHEL 6.10

Version-Release number of selected component (if applicable):

kernel-2.6.32-573.el6.x86_64

How reproducible:

Test crashing the hyperv guest system with the following parameters set in kdump.conf:

  ---------------------
  ext3 LABEL=/log2
  path /var/crash
  core_collector makedumpfile -c --message-level 1 -d 31
  blacklist hv_utils hv_netvsc hid-hyperv hyperv_fd
  disk_timeout 100
  extra_modules ata_piix sr_mod sd_mod
  default reboot
  force_rebuild 1
  ----------------------

Issue is intermittent, but occurred every 3 crashes or so.

Actual results:

Crash intermittently fails.

Expected results:

Crash should work every time.  It was found that the upstream LIS fixes the issue.
Requesting that this level or equivalent be added to 6.10.

https://www.microsoft.com/en-us/download/details.aspx?id=51612

Comment 1 Vitaly Kuznetsov 2017-01-31 17:57:22 UTC
(In reply to John Pittman from comment #0)
> Description of problem:
> 
> Virtual guests on Microsoft hypervisor failing to dump vmcore intermittently
> with a "lost interrupt".
> 
> Issue can be seen below:
>   - https://paste.fedoraproject.org/541688/raw
> 
> Requesting to include LIS 4.1.3 or the module equivalent in RHEL 6.10
> 
> Version-Release number of selected component (if applicable):
> 
> kernel-2.6.32-573.el6.x86_64
> 
> How reproducible:
> 
> Test crashing the hyperv guest system with the following parameters set in
> kdump.conf:
> 
>   ---------------------
>   ext3 LABEL=/log2
>   path /var/crash
>   core_collector makedumpfile -c --message-level 1 -d 31
>   blacklist hv_utils hv_netvsc hid-hyperv hyperv_fd

I don't think this blacklist is needed.

>   disk_timeout 100
>   extra_modules ata_piix sr_mod sd_mod

Ditto. When running under Hyper-V you need to use Hyper-V drivers all the time, they should normally work even after kdump.

>   default reboot
>   force_rebuild 1
>   ----------------------
> 
> Issue is intermittent, but occurred every 3 crashes or so.
> 
> Actual results:
> 
> Crash intermittently fails.
> 
> Expected results:
> 
> Crash should work every time.  It was found that the upstream LIS fixes the
> issue.
> Requesting that this level or equivalent be added to 6.10.
> 
> https://www.microsoft.com/en-us/download/details.aspx?id=51612

All Hyper-V drivers and fixes are in the upstream Linux kernel, we backport them to RHEL when necessary. From your log it seems you're trying to do kdump by injecting NMI with Debug-VM from the host. The issue you see is supposed to be already fixed in RHEL6, see https://bugzilla.redhat.com/show_bug.cgi?id=1333167
If you can, please try the latest 6.9 kernel, it should work. Please report in the original BZ if it doesn't.

*** This bug has been marked as a duplicate of bug 1333167 ***


Note You need to log in before you can comment on or make changes to this bug.