Bug 1418096 - Add crudini to the OSP ISO
Summary: Add crudini to the OSP ISO
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Quickstart Cloud Installer
Classification: Red Hat
Component: Installation - RHELOSP
Version: 1.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 1.1
Assignee: John Matthews
QA Contact: Tasos Papaioannou
Dan Macpherson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-31 20:27 UTC by Jason Montleon
Modified: 2017-02-28 01:45 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-28 01:45:41 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:0335 0 normal SHIPPED_LIVE Red Hat Quickstart Installer 1.1 2017-02-28 06:36:13 UTC

Description Jason Montleon 2017-01-31 20:27:18 UTC
Description of problem:
crudini is not installed as part of the iso installtion. It's helpful for making changes to OSP configs. 

Version-Release number of selected component (if applicable):
latest qci 1.1 iso

How reproducible:
always

Steps to Reproduce:
1. install qci ooo 1.1 from iso
2. run the setup
3. try to use crudini to make a config change

Actual results:
command is not available

Expected results:
command is available

Additional info:
package is already tagged into the list of packages we're using. we just need to add a dep to the meta package to ensure it gets installed.

Comment 1 Jason Montleon 2017-01-31 20:30:48 UTC
https://github.com/fusor/fusor-tripleo/pull/7

Comment 2 Dylan Murray 2017-02-02 17:37:12 UTC
This fix is in QCIOOO-10.0-RHEL-7-20170202.t.0

Comment 3 Tasos Papaioannou 2017-02-03 20:04:11 UTC
I don't see crudini or the requirement in fusor-tripleo on QCIOOO-10.0-RHEL-7-20170202.t.0:

# rpm -q fusor-tripleo
fusor-tripleo-1.1.3-1.el7sat.noarch

# rpm -qR fusor-tripleo | grep crud

# rpm -q crudini
package crudini is not installed

Comment 4 Dylan Murray 2017-02-06 16:06:38 UTC
Sorry about that, I missed his PR when rebuilding. This fix is in QCIOOO-10.0-RHEL-7-20170206.t.0.

Comment 5 Tasos Papaioannou 2017-02-06 18:43:35 UTC
It looks like QCIOOO-10.0-RHEL-7-20170206.t.0 doesn't have the updated fusor-tripleo package either:

# mount QCIOOO-10.0-RHEL-7-20170206.t.0-QCIOOO-x86_64-dvd1.iso mnt

# ls -l mnt/Packages/fusor-tripleo-1.1.3-1.el7sat.noarch.rpm 
-r--r--r--. 1 root root 4424 Jan 18 15:50 mnt/Packages/fusor-tripleo-1.1.3-1.el7sat.noarch.rpm

# ls mnt/Packages/crud*
ls: cannot access mnt/Packages/crud*: No such file or directory

Comment 7 Dylan Murray 2017-02-06 20:45:16 UTC
Jason was able to fix my issue which was causing fusor-tripleo to not be updated. This is fixed in. QCIOOO-10.0-RHEL-7-20170206.t.1

Comment 8 Tasos Papaioannou 2017-02-06 21:36:38 UTC
Verified on QCIOOO-10.0-RHEL-7-20170206.t.1.

Comment 10 errata-xmlrpc 2017-02-28 01:45:41 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:0335


Note You need to log in before you can comment on or make changes to this bug.