Bug 1418102 - Base Runtime FTBFS: qtwebkit-2.3.4-11.fc24
Summary: Base Runtime FTBFS: qtwebkit-2.3.4-11.fc24
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Deadline: 2017-02-14
Product: Fedora
Classification: Fedora
Component: qtwebkit
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: BaseRuntimeFTBFS
TreeView+ depends on / blocked
 
Reported: 2017-01-31 21:19 UTC by Merlin Mathesius
Modified: 2017-02-01 16:02 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-01 11:52:05 UTC
Type: Bug


Attachments (Terms of Use)
proposed patch to correct FTBFS issue (1.12 KB, patch)
2017-01-31 21:22 UTC, Merlin Mathesius
no flags Details | Diff

Description Merlin Mathesius 2017-01-31 21:19:23 UTC
Description of problem:
When attempting to rebuild portions of the frozen package set of Fedora 25 for the Base Runtime effort, we discovered that qtwebkit fails to build due to a missing BuildRequires on python due to python being removed from the default buildroot. This issue also manifests itself in Rawhide where only python3 is present in the buildroot.

Version-Release number of selected component (if applicable):
qtwebkit-2.3.4-11.fc24

How reproducible:
Every time

Steps to Reproduce (rawhide):
1. fedpkg clone qtwebkit
2. cd qtwebkit
3. fedpkg switch-branch master
4. fedpkg mockbuild

Actual results:
/bin/sh: python: command not found

Expected results:
Successful build of the package.

Additional info:
This is needed as part of the Base Runtime effort.

Attached is a patch that adds the missing BuildRequires for python.

Please apply the patch or respond with a reason it should not be applied within two weeks. After that time, a provenpackager will go ahead and apply it.

Comment 1 Merlin Mathesius 2017-01-31 21:22:09 UTC
Created attachment 1246453 [details]
proposed patch to correct FTBFS issue

Comment 2 Rex Dieter 2017-02-01 11:52:05 UTC
patch applied, building for rawhide.

Let me know if you need a f25 build/update as well.

Comment 3 Merlin Mathesius 2017-02-01 16:02:42 UTC
Thank you for the quick fix! The build for rawhide only is fine--the previous version still builds correctly for F25.


Note You need to log in before you can comment on or make changes to this bug.