Bug 1418106 - Must pass ssh_public_key to Class[Fusor] at /usr/share/gems/gems/kafo-0.7.6.1/modules/kafo_configure/manifests/init.pp:14 on node <sat6_fqdn>
Summary: Must pass ssh_public_key to Class[Fusor] at /usr/share/gems/gems/kafo-0.7.6.1...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Quickstart Cloud Installer
Classification: Red Hat
Component: fusor-installer
Version: 1.1
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 1.1
Assignee: Jason Montleon
QA Contact: Tasos Papaioannou
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-31 21:50 UTC by Thom Carlin
Modified: 2017-02-28 01:45 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-28 01:45:45 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:0335 0 normal SHIPPED_LIVE Red Hat Quickstart Installer 1.1 2017-02-28 06:36:13 UTC

Description Thom Carlin 2017-01-31 21:50:15 UTC
Description of problem:

(After RPM install) During fusor-installer, get error message

Version-Release number of selected component (if applicable):

1.1.0-1.el7

How reproducible:

Uncertain

Steps to Reproduce:
1. Install QCI using RPM install method in documentation on minimal,updated RHEL 7 system
2. Run fusor-installer
3. Check /var/log/fusor-installer/fusor-installer.log

Actual results:

Error in log

Expected results:

No error
Successful run of fusor-installer

Additional info:

Stage content server

[ERROR 2017-01-31 16:34:22 main]  Must pass ssh_public_key to Class[Fusor] at /usr/share/gems/gems/kafo-0.7.6.1/modules/kafo_configure/manifests/init.pp:14 on node <<sat6_fqdn>>
[ INFO 2017-01-31 16:34:22 main] /usr/share/ruby/vendor_ruby/puppet/util/errors.rb:106:in `fail'
[ INFO 2017-01-31 16:34:22 main] /usr/share/ruby/vendor_ruby/puppet/resource.rb:482:in `block in validate_complete'
[ INFO 2017-01-31 16:34:22 main] /usr/share/ruby/vendor_ruby/puppet/resource.rb:480:in `each'
[ INFO 2017-01-31 16:34:22 main] /usr/share/ruby/vendor_ruby/puppet/resource.rb:480:in `validate_complete'
[ INFO 2017-01-31 16:34:22 main] /usr/share/ruby/vendor_ruby/puppet/resource/type.rb:314:in `set_resource_parameters'
[ INFO 2017-01-31 16:34:22 main] /usr/share/ruby/vendor_ruby/puppet/resource/type.rb:115:in `evaluate_code'
[ INFO 2017-01-31 16:34:22 main] /usr/share/ruby/vendor_ruby/puppet/parser/resource.rb:81:in `block in evaluate'
[ INFO 2017-01-31 16:34:22 main] /usr/share/ruby/vendor_ruby/puppet/util/profiler/around_profiler.rb:58:in `profile'
[ INFO 2017-01-31 16:34:22 main] /usr/share/ruby/vendor_ruby/puppet/util/profiler.rb:51:in `profile'
[ INFO 2017-01-31 16:34:22 main] /usr/share/ruby/vendor_ruby/puppet/parser/resource.rb:77:in `evaluate'
[ INFO 2017-01-31 16:34:22 main] /usr/share/ruby/vendor_ruby/puppet/parser/compiler.rb:236:in `each'
[ INFO 2017-01-31 16:34:22 main] /usr/share/ruby/vendor_ruby/puppet/parser/compiler.rb:236:in `evaluate_classes'
[ INFO 2017-01-31 16:34:22 main] /usr/share/ruby/vendor_ruby/puppet/parser/functions/include.rb:31:in `block in <top (required)>'
[ INFO 2017-01-31 16:34:22 main] /usr/share/ruby/vendor_ruby/puppet/parser/functions.rb:164:in `block (2 levels) in newfunction'
[ INFO 2017-01-31 16:34:22 main] /usr/share/ruby/vendor_ruby/puppet/util/profiler/around_profiler.rb:58:in `profile'
[ INFO 2017-01-31 16:34:22 main] /usr/share/ruby/vendor_ruby/puppet/util/profiler.rb:51:in `profile'
[ INFO 2017-01-31 16:34:22 main] /usr/share/ruby/vendor_ruby/puppet/parser/functions.rb:157:in `block in newfunction'
[ INFO 2017-01-31 16:34:22 main] /usr/share/ruby/vendor_ruby/puppet/parser/functions/hiera_include.rb:49:in `block in <module:Functions>'
[ INFO 2017-01-31 16:34:22 main] /usr/share/ruby/vendor_ruby/puppet/parser/functions.rb:164:in `block (2 levels) in newfunction'
[ INFO 2017-01-31 16:34:22 main] /usr/share/ruby/vendor_ruby/puppet/util/profiler/around_profiler.rb:58:in `profile'
[ INFO 2017-01-31 16:34:22 main] /usr/share/ruby/vendor_ruby/puppet/util/profiler.rb:51:in `profile'
[ INFO 2017-01-31 16:34:22 main] /usr/share/ruby/vendor_ruby/puppet/parser/functions.rb:157:in `block in newfunction'
[ INFO 2017-01-31 16:34:22 main] /usr/share/ruby/vendor_ruby/puppet/parser/ast/function.rb:42:in `evaluate'
[ INFO 2017-01-31 16:34:22 main] /usr/share/ruby/vendor_ruby/puppet/parser/ast.rb:61:in `safeevaluate'
[ INFO 2017-01-31 16:34:22 main] /usr/share/ruby/vendor_ruby/puppet/parser/ast/block_expression.rb:11:in `block in evaluate'
[ INFO 2017-01-31 16:34:22 main] /usr/share/ruby/vendor_ruby/puppet/parser/ast/block_expression.rb:10:in `each'
[ INFO 2017-01-31 16:34:22 main] /usr/share/ruby/vendor_ruby/puppet/parser/ast/block_expression.rb:10:in `evaluate'
[ INFO 2017-01-31 16:34:22 main] /usr/share/ruby/vendor_ruby/puppet/parser/ast.rb:61:in `safeevaluate'
[ INFO 2017-01-31 16:34:22 main] /usr/share/ruby/vendor_ruby/puppet/resource/type.rb:129:in `evaluate_code'
[ INFO 2017-01-31 16:34:22 main] /usr/share/ruby/vendor_ruby/puppet/parser/resource.rb:81:in `block in evaluate'
[ INFO 2017-01-31 16:34:22 main] /usr/share/ruby/vendor_ruby/puppet/util/profiler/around_profiler.rb:58:in `profile'
[ INFO 2017-01-31 16:34:22 main] /usr/share/ruby/vendor_ruby/puppet/util/profiler.rb:51:in `profile'
[ INFO 2017-01-31 16:34:22 main] /usr/share/ruby/vendor_ruby/puppet/parser/resource.rb:77:in `evaluate'
[ INFO 2017-01-31 16:34:22 main] /usr/share/ruby/vendor_ruby/puppet/parser/compiler.rb:236:in `each'
[ INFO 2017-01-31 16:34:22 main] /usr/share/ruby/vendor_ruby/puppet/parser/compiler.rb:236:in `evaluate_classes'
[ INFO 2017-01-31 16:34:22 main] /usr/share/ruby/vendor_ruby/puppet/parser/functions/include.rb:31:in `block in <top (required)>'
[ INFO 2017-01-31 16:34:22 main] /usr/share/ruby/vendor_ruby/puppet/parser/functions.rb:164:in `block (2 levels) in newfunction'
[ INFO 2017-01-31 16:34:22 main] /usr/share/ruby/vendor_ruby/puppet/util/profiler/around_profiler.rb:58:in `profile'
[ INFO 2017-01-31 16:34:22 main] /usr/share/ruby/vendor_ruby/puppet/util/profiler.rb:51:in `profile'
[ INFO 2017-01-31 16:34:22 main] /usr/share/ruby/vendor_ruby/puppet/parser/functions.rb:157:in `block in newfunction'
[ INFO 2017-01-31 16:34:22 main] /usr/share/ruby/vendor_ruby/puppet/parser/functions/hiera_include.rb:49:in `block in <module:Functions>'
[ INFO 2017-01-31 16:34:22 main] /usr/share/ruby/vendor_ruby/puppet/parser/functions.rb:164:in `block (2 levels) in newfunction'
[ INFO 2017-01-31 16:34:22 main] /usr/share/ruby/vendor_ruby/puppet/util/profiler/around_profiler.rb:58:in `profile'
[ INFO 2017-01-31 16:34:22 main] /usr/share/ruby/vendor_ruby/puppet/util/profiler.rb:51:in `profile'
[ INFO 2017-01-31 16:34:22 main] /usr/share/ruby/vendor_ruby/puppet/parser/functions.rb:157:in `block in newfunction'
[ INFO 2017-01-31 16:34:22 main] /usr/share/ruby/vendor_ruby/puppet/parser/ast/function.rb:42:in `evaluate'
[ INFO 2017-01-31 16:34:22 main] /usr/share/ruby/vendor_ruby/puppet/parser/ast.rb:61:in `safeevaluate'
[ INFO 2017-01-31 16:34:22 main] /usr/share/ruby/vendor_ruby/puppet/parser/ast/block_expression.rb:11:in `block in evaluate'
[ INFO 2017-01-31 16:34:22 main] /usr/share/ruby/vendor_ruby/puppet/parser/ast/block_expression.rb:10:in `each'
[ INFO 2017-01-31 16:34:22 main] /usr/share/ruby/vendor_ruby/puppet/parser/ast/block_expression.rb:10:in `evaluate'
[ INFO 2017-01-31 16:34:22 main] /usr/share/ruby/vendor_ruby/puppet/parser/ast.rb:61:in `safeevaluate'
[ INFO 2017-01-31 16:34:22 main] /usr/share/ruby/vendor_ruby/puppet/resource/type.rb:129:in `evaluate_code'
[ INFO 2017-01-31 16:34:22 main] /usr/share/ruby/vendor_ruby/puppet/parser/resource.rb:81:in `block in evaluate'
[ INFO 2017-01-31 16:34:22 main] /usr/share/ruby/vendor_ruby/puppet/util/profiler/around_profiler.rb:58:in `profile'
[ INFO 2017-01-31 16:34:22 main] /usr/share/ruby/vendor_ruby/puppet/util/profiler.rb:51:in `profile'
[ INFO 2017-01-31 16:34:22 main] /usr/share/ruby/vendor_ruby/puppet/parser/resource.rb:77:in `evaluate'
[ INFO 2017-01-31 16:34:22 main] /usr/share/ruby/vendor_ruby/puppet/parser/compiler.rb:236:in `each'
[ INFO 2017-01-31 16:34:22 main] /usr/share/ruby/vendor_ruby/puppet/parser/compiler.rb:236:in `evaluate_classes'
[ INFO 2017-01-31 16:34:22 main] /usr/share/ruby/vendor_ruby/puppet/parser/functions/include.rb:31:in `block in <top (required)>'
[ INFO 2017-01-31 16:34:22 main] /usr/share/ruby/vendor_ruby/puppet/parser/functions.rb:164:in `block (2 levels) in newfunction'
[ INFO 2017-01-31 16:34:22 main] /usr/share/ruby/vendor_ruby/puppet/util/profiler/around_profiler.rb:58:in `profile'
[ INFO 2017-01-31 16:34:22 main] /usr/share/ruby/vendor_ruby/puppet/util/profiler.rb:51:in `profile'
[ INFO 2017-01-31 16:34:22 main] /usr/share/ruby/vendor_ruby/puppet/parser/functions.rb:157:in `block in newfunction'
[ INFO 2017-01-31 16:34:22 main] /usr/share/ruby/vendor_ruby/puppet/parser/ast/function.rb:42:in `evaluate'
[ INFO 2017-01-31 16:34:22 main] /usr/share/ruby/vendor_ruby/puppet/parser/ast.rb:61:in `safeevaluate'
[ INFO 2017-01-31 16:34:22 main] /usr/share/ruby/vendor_ruby/puppet/parser/ast/block_expression.rb:11:in `block in evaluate'
[ INFO 2017-01-31 16:34:22 main] /usr/share/ruby/vendor_ruby/puppet/parser/ast/block_expression.rb:10:in `each'
[ INFO 2017-01-31 16:34:22 main] /usr/share/ruby/vendor_ruby/puppet/parser/ast/block_expression.rb:10:in `evaluate'
[ INFO 2017-01-31 16:34:22 main] /usr/share/ruby/vendor_ruby/puppet/parser/ast.rb:61:in `safeevaluate'
[ INFO 2017-01-31 16:34:22 main] /usr/share/ruby/vendor_ruby/puppet/resource/type.rb:129:in `evaluate_code'
[ INFO 2017-01-31 16:34:22 main] /usr/share/ruby/vendor_ruby/puppet/parser/resource.rb:81:in `block in evaluate'
[ INFO 2017-01-31 16:34:22 main] /usr/share/ruby/vendor_ruby/puppet/util/profiler/around_profiler.rb:58:in `profile'
[ INFO 2017-01-31 16:34:22 main] /usr/share/ruby/vendor_ruby/puppet/util/profiler.rb:51:in `profile'
[ INFO 2017-01-31 16:34:22 main] /usr/share/ruby/vendor_ruby/puppet/parser/resource.rb:77:in `evaluate'
[ INFO 2017-01-31 16:34:22 main] /usr/share/ruby/vendor_ruby/puppet/parser/compiler.rb:426:in `evaluate_main'
[ INFO 2017-01-31 16:34:22 main] /usr/share/ruby/vendor_ruby/puppet/parser/compiler.rb:135:in `block (2 levels) in compile'
[ INFO 2017-01-31 16:34:22 main] /usr/share/ruby/vendor_ruby/puppet/util/profiler/around_profiler.rb:58:in `profile'
[ INFO 2017-01-31 16:34:22 main] /usr/share/ruby/vendor_ruby/puppet/util/profiler.rb:51:in `profile'
[ INFO 2017-01-31 16:34:22 main] /usr/share/ruby/vendor_ruby/puppet/parser/compiler.rb:135:in `block in compile'
[ INFO 2017-01-31 16:34:22 main] /usr/share/ruby/vendor_ruby/puppet/context.rb:64:in `override'
[ INFO 2017-01-31 16:34:22 main] /usr/share/ruby/vendor_ruby/puppet.rb:246:in `override'
[ INFO 2017-01-31 16:34:22 main] /usr/share/ruby/vendor_ruby/puppet/parser/compiler.rb:121:in `compile'
[ INFO 2017-01-31 16:34:22 main] /usr/share/ruby/vendor_ruby/puppet/parser/compiler.rb:34:in `compile'
[ INFO 2017-01-31 16:34:22 main] /usr/share/ruby/vendor_ruby/puppet/indirector/catalog/compiler.rb:95:in `block (2 levels) in compile'
[ INFO 2017-01-31 16:34:22 main] /usr/share/ruby/vendor_ruby/puppet/util/profiler/around_profiler.rb:58:in `profile'
[ INFO 2017-01-31 16:34:22 main] /usr/share/ruby/vendor_ruby/puppet/util/profiler.rb:51:in `profile'
[ INFO 2017-01-31 16:34:22 main] /usr/share/ruby/vendor_ruby/puppet/indirector/catalog/compiler.rb:93:in `block in compile'
[ INFO 2017-01-31 16:34:22 main] /usr/share/ruby/vendor_ruby/puppet/util.rb:161:in `block in benchmark'
[ INFO 2017-01-31 16:34:22 main] /usr/share/ruby/benchmark.rb:296:in `realtime'
[ INFO 2017-01-31 16:34:22 main] /usr/share/ruby/vendor_ruby/puppet/util.rb:160:in `benchmark'
[ INFO 2017-01-31 16:34:22 main] /usr/share/ruby/vendor_ruby/puppet/indirector/catalog/compiler.rb:92:in `compile'
[ INFO 2017-01-31 16:34:22 main] /usr/share/ruby/vendor_ruby/puppet/indirector/catalog/compiler.rb:52:in `find'
[ INFO 2017-01-31 16:34:22 main] /usr/share/ruby/vendor_ruby/puppet/indirector/indirection.rb:201:in `find'
[ INFO 2017-01-31 16:34:22 main] /usr/share/ruby/vendor_ruby/puppet/application/apply.rb:222:in `block in main'
[ INFO 2017-01-31 16:34:22 main] /usr/share/ruby/vendor_ruby/puppet/context.rb:64:in `override'
[ INFO 2017-01-31 16:34:22 main] /usr/share/ruby/vendor_ruby/puppet.rb:246:in `override'
[ INFO 2017-01-31 16:34:22 main] /usr/share/ruby/vendor_ruby/puppet/application/apply.rb:198:in `main'
[ INFO 2017-01-31 16:34:22 main] /usr/share/ruby/vendor_ruby/puppet/application/apply.rb:159:in `run_command'
[ INFO 2017-01-31 16:34:22 main] /usr/share/ruby/vendor_ruby/puppet/application.rb:381:in `block (2 levels) in run'
[ INFO 2017-01-31 16:34:22 main] /usr/share/ruby/vendor_ruby/puppet/application.rb:507:in `plugin_hook'
[ INFO 2017-01-31 16:34:22 main] /usr/share/ruby/vendor_ruby/puppet/application.rb:381:in `block in run'
[ INFO 2017-01-31 16:34:22 main] /usr/share/ruby/vendor_ruby/puppet/util.rb:496:in `exit_on_fail'
[ INFO 2017-01-31 16:34:22 main] /usr/share/ruby/vendor_ruby/puppet/application.rb:381:in `run'
[ INFO 2017-01-31 16:34:22 main] /usr/share/ruby/vendor_ruby/puppet/util/command_line.rb:146:in `run'
[ INFO 2017-01-31 16:34:22 main] /usr/share/ruby/vendor_ruby/puppet/util/command_line.rb:92:in `execute'
[ INFO 2017-01-31 16:34:22 main] /usr/bin/puppet:8:in `<main>'

foreman-debug to follow in private attachment

Comment 2 Thom Carlin 2017-01-31 22:14:04 UTC
Workaround: yum downgrade rubygem-kafo

Comment 3 Jason Montleon 2017-02-01 13:40:46 UTC
What version of rubygem-kafo did you have? What version did you downgrade to?

Comment 4 Thom Carlin 2017-02-01 14:07:27 UTC
 Downgraded              0.7.6.1-1.el7sat.noarch @rhel-7-server-satellite-6.2-rpms
to rubygem-kafo-0.7.6-1.el7sat.noarch   @qci-1.1-for-rhel-7-rpms

Comment 6 Jason Montleon 2017-02-01 15:37:42 UTC
I was able to reproduce this with the newest rubygem-kafo.

I don't know what ssh_public_key is supposedly being used for. It's not clear to me that anything is being done with it. If that's the case we can remove a couple lines and the installer runs normally. Otherwise we'll have to dig deeper.

Comment 7 Thom Carlin 2017-02-01 15:46:54 UTC
https://access.redhat.com/errata/RHBA-2017:0197 provided the newer rubygem-kafo

Comment 8 Jason Montleon 2017-02-01 18:29:44 UTC
https://github.com/fusor/fusor-installer/pull/108

Comment 9 Dylan Murray 2017-02-02 13:36:49 UTC
This was fixed in QCI-1.1-RHEL-7-20170201.t.0.

Comment 10 Tasos Papaioannou 2017-02-03 20:53:57 UTC
Verified on QCI-1.1-RHEL-7-20170202.t.2.

Comment 11 Thom Carlin 2017-02-08 19:57:30 UTC
FailedQA on RPM QCI testing.

The relevant code in the PR is part of fusor-installer RPM:
* Working (ISO) uses 1:1.1.12-1.el7
* Broken (RPM) uses 1.1.11-1.el7

This is most likely a CDN problem, not a developer issue.

Comment 12 Thom Carlin 2017-02-08 21:21:06 UTC
Corrected Status to ON_QA.  

Please don't move to VERIFIED unless a RPM install was successful.  No foul, this was an unusual circumstance...

Comment 14 errata-xmlrpc 2017-02-28 01:45:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:0335


Note You need to log in before you can comment on or make changes to this bug.