Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1418111 - [ceph-ansible 2.1.5-1] Error ENOENT: error obtaining 'initial_mon_keyring':
Summary: [ceph-ansible 2.1.5-1] Error ENOENT: error obtaining 'initial_mon_keyring':
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Storage Console
Classification: Red Hat
Component: ceph-ansible
Version: 2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 3
Assignee: Sébastien Han
QA Contact: ceph-qe-bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-31 22:15 UTC by Vasu Kulkarni
Modified: 2017-01-31 23:11 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-31 23:11:55 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Vasu Kulkarni 2017-01-31 22:15:29 UTC
Description of problem:

with ceph-ansible 2.1.5 seeing the following fatal during playbook

fatal: [ceph-jenkins-build-run529-node10-mon]: FAILED! => {"changed": false, "cmd": ["ceph", "--cluster", "ceph", "config-key", "get", "initial_mon_keyring"], "delta": "0:00:00.165319", "end": "2017-01-31 16:29:02.352734", "failed": true, "rc": 2, "start": "2017-01-31 16:29:02.187415", "stderr": "Error ENOENT: error obtaining 'initial_mon_keyring': (2) No such file or directory", "stdout": "", "stdout_lines": [], "warnings": []}
...ignoring

full logs:
https://ceph-jenkins.rhev-ci-vms.eng.rdu2.redhat.com/job/ceph-ansible-sanity-xenial-2.x/39/consoleFull

https://ceph-jenkins.rhev-ci-vms.eng.rdu2.redhat.com/job/ceph-ansible-sanity-2.x/104/consoleFull

Version-Release number of selected component (if applicable):
ceph-ansible 2.1.5 


How reproducible:
1/1

Comment 2 Vasu Kulkarni 2017-01-31 23:11:55 UTC
Andrew debugged this and it was due to hdparm not installed on node9-mon, and ceph never got installed on that node causing other task to fail later. closing this as not a bug, a newer run worked.


Note You need to log in before you can comment on or make changes to this bug.