Bug 1418112 - Regression: batctl p gets '/sys/kernel/debug//batman_adv/bat0/socket': No such file or directory
Summary: Regression: batctl p gets '/sys/kernel/debug//batman_adv/bat0/socket': No suc...
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: batctl
Version: 25
Hardware: Unspecified
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Felix Kaechele
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-31 22:33 UTC by Stuart D Gathman
Modified: 2017-02-01 14:48 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-01 13:59:19 UTC
Type: Bug


Attachments (Terms of Use)

Description Stuart D Gathman 2017-01-31 22:33:57 UTC
Description of problem:
# batctl p b.glinet3
Error - can't open a connection to the batman adv kernel module via the socket '/sys/kernel/debug//batman_adv/bat0/socket': No such file or directory
Check whether the module is loaded and active.

Version-Release number of selected component (if applicable):
batctl-2016.4-1.fc25.x86_64

How reproducible:
always

Steps to Reproduce:
0. connect to batman mesh
1. batctl p 1:2:3:4:5:6  # use actual neighbor MAC from batctl o if desired
2.

Actual results:
Error - can't open a connection to the batman adv kernel module via the socket '/sys/kernel/debug//batman_adv/bat0/socket': No such file or directory
Check whether the module is loaded and active.

Expected results:
PING 74:e5:43:ae:8e:6b (74:e5:43:ae:8e:6b) 20(48) bytes of data
20 bytes from 74:e5:43:ae:8e:6b icmp_seq=1 ttl=50 time=1.98 ms
...

Additional info:
Works in f23 and f24

Comment 1 Felix Kaechele 2017-02-01 08:42:58 UTC
Hi Stuart,

thanks for reporting this.
Can you check if this is still an issue with the latest batctl version?
See the update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-84c28282d8
It's in the testing repos as of now and should be relatively easy to install.

If the issue still persists can you please send me the output of
dmesg | grep batman_adv

Also please check if you see any AVC denials with SELinux enabled.

If this turns out to be an issue with the kernel module I will provide you with an update rpm so you can test.

Comment 2 Stuart D Gathman 2017-02-01 13:59:19 UTC
Fixed in batctl-2016.5-1.fc25


Note You need to log in before you can comment on or make changes to this bug.