Bug 1418167 - systemd disable echo back after authentication timeout
Summary: systemd disable echo back after authentication timeout
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: systemd
Version: 7.3
Hardware: All
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: systemd-maint
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Depends On:
Blocks: 1553558
TreeView+ depends on / blocked
 
Reported: 2017-02-01 05:06 UTC by masanari iida
Modified: 2021-01-15 07:31 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-01-15 07:31:12 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description masanari iida 2017-02-01 05:06:55 UTC
Description of problem:
When non-root user use "systemctl",  it require the authentication.
But if user never input, the authentication become timeout as expected.
After the prompt comes back, user can not see the input of his/her.

Version-Release number of selected component (if applicable):
systemd-219-19.el7,  systemd-219-30.el7

How reproducible:
Always


Steps to Reproduce:
1. Login as non-root user.
2. Stop postfix service.
   When pam asked for authentication, never input and wait for timeout.
   $ systemctl stop postfix.service

==== AUTHENTICATING FOR org.freedesktop.systemd1.manage-units ===
Authentication is required to manage system services or units.
Authenticating as: root
Password:   <=   Never input 

After timeout

Password: Failed to stop postfix.service: Connection timed out
polkit-agent-helper-1: pam_authenticate failed: Authentication failure

3. Shell prompt comes back.
   Then type something to the shell.

Actual results:
Can not see my input from the shell.

Expected results:
Can see my input from the shell.

Additional info:
Collect stty setting before and after the 
"$ systemctl stop postfix.service".

# diff stty-before.txt stty-after.txt
9c9
< isig icanon iexten echo echoe echok -echonl -noflsh -xcase -tostop -echoprt
---
> isig icanon iexten -echo -echoe -echok -echonl -noflsh -xcase -tostop -echoprt

echo, echoe, echok are disabled.

I type "stty echo" while no echo-back from shell,
then the shell re-start to echo back.

Comment 1 masanari iida 2017-02-01 05:18:28 UTC
-- RHEL7 ---
In case of Authentication failure because of wrong password,
this symptom never occurred.

In case of Authentication interrupt by CTRL+C,
this symptom never occurred.

In case of Authentication failure because of timeout,
this symptom OCCURRED.

-- Fedora 24 --
In case of Authentication failure because of timeout,
this symptom never occurred.
Test with systemd-229-16.fc24

Comment 4 Need Real Name 2018-03-08 13:04:00 UTC
Possibly a duplicate of #1325512

Comment 6 RHEL Program Management 2021-01-15 07:31:12 UTC
After evaluating this issue, there are no plans to address it further or fix it in an upcoming release.  Therefore, it is being closed.  If plans change such that this issue will be fixed in an upcoming release, then the bug can be reopened.


Note You need to log in before you can comment on or make changes to this bug.