Bug 1418201 - nfs-ganesha crashed when same file is copied from 2 different clients to the same mountpoint
Summary: nfs-ganesha crashed when same file is copied from 2 different clients to the ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RGW
Version: 2.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 2.2
Assignee: Matt Benjamin (redhat)
QA Contact: Hemanth Kumar
URL:
Whiteboard:
Depends On:
Blocks: 1420328
TreeView+ depends on / blocked
 
Reported: 2017-02-01 09:28 UTC by Hemanth Kumar
Modified: 2017-07-30 15:55 UTC (History)
10 users (show)

Fixed In Version: RHEL: nfs-ganesha-2.4.2-4.el7cp Ubuntu: nfs-ganesha_2.4.2-4redhat1xenial
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1420328 (view as bug list)
Environment:
Last Closed: 2017-03-14 15:48:45 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:0514 0 normal SHIPPED_LIVE Red Hat Ceph Storage 2.2 bug fix and enhancement update 2017-03-21 07:24:26 UTC

Description Hemanth Kumar 2017-02-01 09:28:54 UTC
Description of problem:
------------------------
Copied same file to the mountpoint from 2 different client leads to nfs-ganesha crash.


Version-Release number of selected component (if applicable):
------------------------------
# rpm -qa | grep ganesha
nfs-ganesha-rgw-2.4.2-1.el7cp.x86_64
nfs-ganesha-2.4.2-1.el7cp.x86_64

# rpm -qa | grep ceph
ceph-radosgw-10.2.5-12.el7cp.x86_64

How reproducible:
------------------
100%

Steps to Reproduce:
1. Create a nfs share and mount from 2 different linux clients
2. downloaded a rhel iso on both the clients
3. copied the downloaded ISO file to the mounted share from both the clients at same time and it leads to a crash..

Actual results:
---------------
nfs-ganesha crashed

Expected results:
-----------------
Should avoid copying and these kind of scenarios should be handled by locking mechanism.

------------------------------------------------------------------------------
     0> 2017-01-31 15:13:49.178306 7f828cf81700 -1 *** Caught signal (Segmentation fault) **
 in thread 7f828cf81700 thread_name:ganesha.nfsd

 ceph version 10.2.5-12.el7cp (8614488f8c3e7a9be34e58fb1aaf23416156152c)
 1: (()+0x56dc0a) [0x7f8429b3dc0a]
 2: (()+0xf370) [0x7f8436392370]
 3: (rgw_getattr()+0x4) [0x7f8429ad3d24]
 4: (rgw_fsal_open2()+0x7a6) [0x7f843322cbb6]
 5: (mdcache_open2()+0x34f) [0x7f8437ed314f]
 6: (fsal_open2()+0x1fb) [0x7f8437e07cfb]
 7: (()+0x2b386) [0x7f8437df3386]
 8: (nfs4_op_open()+0xaa9) [0x7f8437e3b8a9]
 9: (nfs4_Compound()+0x63d) [0x7f8437e2dded]
 10: (nfs_rpc_execute()+0x5bc) [0x7f8437e1ef9c]
 11: (()+0x585fa) [0x7f8437e205fa]
 12: (()+0xe2289) [0x7f8437eaa289]
 13: (()+0x7dc5) [0x7f843638adc5]
 14: (clone()+0x6d) [0x7f8435a5973d]
 NOTE: a copy of the executable, or `objdump -rdS <executable>` is needed to interpret this.

Comment 12 Hemanth Kumar 2017-02-08 13:16:11 UTC
Closing the BZ as suggested since nfs crash was not seen again on latest builds  and have opened a new BZ :1420328 to track the IO errors.

Comment 14 errata-xmlrpc 2017-03-14 15:48:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2017-0514.html


Note You need to log in before you can comment on or make changes to this bug.