Bug 1418214 - GLUSTER_NODE parameter is not available anymore
Summary: GLUSTER_NODE parameter is not available anymore
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: doc-Container_Native_Storage_with_OpenShift
Version: rhgs-3.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Divya
QA Contact: storage-qa-internal@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-01 09:47 UTC by Akram Ben Aissi
Modified: 2017-04-10 07:58 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-04-06 08:22:56 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Akram Ben Aissi 2017-02-01 09:47:52 UTC
Description of problem:

https://access.redhat.com/documentation/en/red-hat-gluster-storage/3.1/single/deployment-guide-for-containerized-red-hat-gluster-storage-in-openshift-enterprise/

The documentation tells:
# oc process glusterfs -v GLUSTERFS_NODE=node1.example.com | oc create -f -


Version-Release number of selected component (if applicable):
3.1.3

How reproducible:
Follow the doc to install the product on OCP

Steps to Reproduce:
1.
2.
3.

Actual results:
The command fails with: no parameter GLUSTERFS_NODE available

Expected results:

The command installs the product
Additional info:

The template now uses a DaemonSet that does not accept this param anymore.
It requires a selector named: storagenode=glusterfs
So the documentation needs an additional step to label glusterfs nodes with the following command:

oc label node node1.example.com storagenode=glusterfs --overwrite

Comment 4 Divya 2017-04-06 08:22:56 UTC
(In reply to Akram Ben Aissi from comment #0)
> Description of problem:
> 

Akram,

In the RHGS 3.1.3 + OCP 3.4 guide [1], we have documented "storagenode=glusterfs" parameter. The command "# oc label nodes 192.168.90.3 storagenode=glusterfs" succeeds without the --overwrite parameter.


I think you are referring to the RHGS 3.1.3 + OCP 3.2 or 3.3 guide [2] where we have documented the "# oc process glusterfs -v GLUSTERFS_NODE=<node_hostname> | oc create -f -" command.

As the command is correctly documented in the latest guide [1], closing the bug as "Not a bug". If you still see an issue, please feel to free to reopen the bug.

Thanks!


[1] https://access.redhat.com/documentation/en-us/red_hat_gluster_storage/3.1/html-single/container-native_storage_for_openshift_container_platform_3.4/#idm140521914416848

[2] https://access.redhat.com/documentation/en-us/red_hat_gluster_storage/3.1/html-single/container-native_storage_for_openshift_container_platform_3.3/#idm140257835157376


Note You need to log in before you can comment on or make changes to this bug.